[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ff0c735e-9e8e-4f26-96eb-3927c26e1e01@redhat.com>
Date: Wed, 13 Dec 2023 20:52:02 -0500
From: Waiman Long <longman@...hat.com>
To: George Stark <gnstark@...utedevices.com>,
andy.shevchenko@...il.com, pavel@....cz, lee@...nel.org,
vadimp@...dia.com, mpe@...erman.id.au, npiggin@...il.com,
christophe.leroy@...roup.eu, hdegoede@...hat.com,
mazziesaccount@...il.com, peterz@...radead.org, mingo@...hat.com,
will@...nel.org, boqun.feng@...il.com, nikitos.tr@...il.com
Cc: linux-leds@...r.kernel.org, linux-kernel@...r.kernel.org,
linuxppc-dev@...ts.ozlabs.org, kernel@...utedevices.com
Subject: Re: [PATCH v3 02/11] locking: add define if mutex_destroy() is not an
empty function
On 12/13/23 17:30, George Stark wrote:
> mutex_destroy() is only a debug helper and an empty function on non-debug
> configurations still we can't legally ignore it because it's the
> established API call and it can be extended theoretically in the future.
> Sometimes it could be useful to know e.g. in the higher-level API if
> mutex_destroy() really does something in the current configuration
> and it's should be called or skipped otherwise for the sake of
> optimization so add dedicated define to recognize these cases.
>
> Signed-off-by: George Stark <gnstark@...utedevices.com>
> ---
> include/linux/mutex.h | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/include/linux/mutex.h b/include/linux/mutex.h
> index a33aa9eb9fc3..2395ce4fcaf6 100644
> --- a/include/linux/mutex.h
> +++ b/include/linux/mutex.h
> @@ -83,6 +83,9 @@ struct mutex {
>
> extern void mutex_destroy(struct mutex *lock);
>
> +/* mutex_destroy() is a real function, not a NOP */
> +#define mutex_destroy mutex_destroy
> +
> #else
>
> # define __DEBUG_MUTEX_INITIALIZER(lockname)
Acked-by: Waiman Long <longman@...hat.com>
Powered by blists - more mailing lists