[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20231214132544.376574-1-hch@lst.de>
Date: Thu, 14 Dec 2023 14:25:33 +0100
From: Christoph Hellwig <hch@....de>
To: linux-mm@...ck.org
Cc: "Matthew Wilcox (Oracle)" <willy@...radead.org>,
linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org,
Jan Kara <jack@...e.com>, David Howells <dhowells@...hat.com>
Subject: Convert write_cache_pages() to an iterator v2
Hi all,
this is basically a report of willy's series of the same name for June.
I picked the lastest version from his (now apparently defunct) git tree,
rebased it to mainline (no coflict, neither for linux-next), reordered
the new fields in struct writeback_control to document what is interface
vs internal, and temporarily dropped the iomap patch due to a conflict
in the VFS tree.
willy: let me know if me reposting it like this is fine, or if you
want me to stop. I'd just really like to see it merged :)
Note that patch 4 is missing your signoff, so we'd need that before
proceeding anyway.
The original cover letter is below:
Dave Howells doesn't like the indirect function call imposed by
write_cache_pages(), so refactor it into an iterator. I took the
opportunity to add the ability to iterate a folio_batch without having
an external variable.
This is against next-20230623. If you try to apply it on top of a tree
which doesn't include the pagevec removal series, IT WILL CRASH because
it won't reinitialise folio_batch->i and the iteration will index out
of bounds.
I have a feeling the 'done' parameter could have a better name, but I
can't think what it might be.
Diffstat:
include/linux/pagevec.h | 18 ++
include/linux/writeback.h | 24 +++
mm/page-writeback.c | 313 +++++++++++++++++++++++++---------------------
3 files changed, 211 insertions(+), 144 deletions(-)
Powered by blists - more mailing lists