[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <d029fafd-658a-44ec-872d-62370c6422d7@arm.com>
Date: Thu, 21 Dec 2023 12:30:41 +0000
From: Metin Kaya <metin.kaya@....com>
To: John Stultz <jstultz@...gle.com>, LKML <linux-kernel@...r.kernel.org>
Cc: Joel Fernandes <joelaf@...gle.com>, Qais Yousef <qyousef@...gle.com>,
Ingo Molnar <mingo@...hat.com>, Peter Zijlstra <peterz@...radead.org>,
Juri Lelli <juri.lelli@...hat.com>,
Vincent Guittot <vincent.guittot@...aro.org>,
Dietmar Eggemann <dietmar.eggemann@....com>,
Valentin Schneider <vschneid@...hat.com>,
Steven Rostedt <rostedt@...dmis.org>, Ben Segall <bsegall@...gle.com>,
Zimuzo Ezeozue <zezeozue@...gle.com>, Youssef Esmat
<youssefesmat@...gle.com>, Mel Gorman <mgorman@...e.de>,
Daniel Bristot de Oliveira <bristot@...hat.com>,
Will Deacon <will@...nel.org>, Waiman Long <longman@...hat.com>,
Boqun Feng <boqun.feng@...il.com>, "Paul E. McKenney" <paulmck@...nel.org>,
Xuewen Yan <xuewen.yan94@...il.com>, K Prateek Nayak
<kprateek.nayak@....com>, Thomas Gleixner <tglx@...utronix.de>,
kernel-team@...roid.com
Subject: Re: [PATCH v7 10/23] sched: Split out __sched() deactivate task logic
into a helper
On 20/12/2023 12:18 am, John Stultz wrote:
> As we're going to re-use the deactivation logic,
> split it into a helper.
>
> Cc: Joel Fernandes <joelaf@...gle.com>
> Cc: Qais Yousef <qyousef@...gle.com>
> Cc: Ingo Molnar <mingo@...hat.com>
> Cc: Peter Zijlstra <peterz@...radead.org>
> Cc: Juri Lelli <juri.lelli@...hat.com>
> Cc: Vincent Guittot <vincent.guittot@...aro.org>
> Cc: Dietmar Eggemann <dietmar.eggemann@....com>
> Cc: Valentin Schneider <vschneid@...hat.com>
> Cc: Steven Rostedt <rostedt@...dmis.org>
> Cc: Ben Segall <bsegall@...gle.com>
> Cc: Zimuzo Ezeozue <zezeozue@...gle.com>
> Cc: Youssef Esmat <youssefesmat@...gle.com>
> Cc: Mel Gorman <mgorman@...e.de>
> Cc: Daniel Bristot de Oliveira <bristot@...hat.com>
> Cc: Will Deacon <will@...nel.org>
> Cc: Waiman Long <longman@...hat.com>
> Cc: Boqun Feng <boqun.feng@...il.com>
> Cc: "Paul E. McKenney" <paulmck@...nel.org>
> Cc: Metin Kaya <Metin.Kaya@....com>
> Cc: Xuewen Yan <xuewen.yan94@...il.com>
> Cc: K Prateek Nayak <kprateek.nayak@....com>
> Cc: Thomas Gleixner <tglx@...utronix.de>
> Cc: kernel-team@...roid.com
> Signed-off-by: John Stultz <jstultz@...gle.com>
> ---
> v6:
> * Define function as static to avoid "no previous prototype"
> warnings as Reported-by: kernel test robot <lkp@...el.com>
> v7:
> * Rename state task_state to be more clear, as suggested by
> Metin Kaya
> ---
> kernel/sched/core.c | 66 +++++++++++++++++++++++++--------------------
> 1 file changed, 37 insertions(+), 29 deletions(-)
>
> diff --git a/kernel/sched/core.c b/kernel/sched/core.c
> index 0ce34f5c0e0c..34acd80b6bd0 100644
> --- a/kernel/sched/core.c
> +++ b/kernel/sched/core.c
> @@ -6571,6 +6571,42 @@ pick_next_task(struct rq *rq, struct task_struct *prev, struct rq_flags *rf)
> # define SM_MASK_PREEMPT SM_PREEMPT
> #endif
>
* Better to have a comment (e.g., in which conditions
try_to_deactivate_task() returns true or false) here.
* try_to_deactivate_task() is temporarily used by 2 commits in the patch
set (i.e., it's only called by __schedule() just like in this patch at
the end of the series). However, it's nice to make that big
__scheduler() function a bit modular as we discussed off-list. So,
should we move this function out of the Proxy Execution patch set to get
it merged independently?
> +static bool try_to_deactivate_task(struct rq *rq, struct task_struct *p,
> + unsigned long task_state)
> +{
> + if (signal_pending_state(task_state, p)) {
> + WRITE_ONCE(p->__state, TASK_RUNNING);
> + } else {
> + p->sched_contributes_to_load =
> + (task_state & TASK_UNINTERRUPTIBLE) &&
> + !(task_state & TASK_NOLOAD) &&
> + !(task_state & TASK_FROZEN);
> +
> + if (p->sched_contributes_to_load)
> + rq->nr_uninterruptible++;
> +
> + /*
> + * __schedule() ttwu()
> + * prev_state = prev->state; if (p->on_rq && ...)
> + * if (prev_state) goto out;
> + * p->on_rq = 0; smp_acquire__after_ctrl_dep();
> + * p->state = TASK_WAKING
> + *
> + * Where __schedule() and ttwu() have matching control dependencies.
> + *
> + * After this, schedule() must not care about p->state any more.
> + */
> + deactivate_task(rq, p, DEQUEUE_SLEEP | DEQUEUE_NOCLOCK);
> +
> + if (p->in_iowait) {
> + atomic_inc(&rq->nr_iowait);
> + delayacct_blkio_start();
> + }
> + return true;
> + }
> + return false;
> +}
> +
> /*
> * __schedule() is the main scheduler function.
> *
> @@ -6662,35 +6698,7 @@ static void __sched notrace __schedule(unsigned int sched_mode)
> */
> prev_state = READ_ONCE(prev->__state);
> if (!(sched_mode & SM_MASK_PREEMPT) && prev_state) {
> - if (signal_pending_state(prev_state, prev)) {
> - WRITE_ONCE(prev->__state, TASK_RUNNING);
> - } else {
> - prev->sched_contributes_to_load =
> - (prev_state & TASK_UNINTERRUPTIBLE) &&
> - !(prev_state & TASK_NOLOAD) &&
> - !(prev_state & TASK_FROZEN);
> -
> - if (prev->sched_contributes_to_load)
> - rq->nr_uninterruptible++;
> -
> - /*
> - * __schedule() ttwu()
> - * prev_state = prev->state; if (p->on_rq && ...)
> - * if (prev_state) goto out;
> - * p->on_rq = 0; smp_acquire__after_ctrl_dep();
> - * p->state = TASK_WAKING
> - *
> - * Where __schedule() and ttwu() have matching control dependencies.
> - *
> - * After this, schedule() must not care about p->state any more.
> - */
> - deactivate_task(rq, prev, DEQUEUE_SLEEP | DEQUEUE_NOCLOCK);
> -
> - if (prev->in_iowait) {
> - atomic_inc(&rq->nr_iowait);
> - delayacct_blkio_start();
> - }
> - }
> + try_to_deactivate_task(rq, prev, prev_state);
> switch_count = &prev->nvcsw;
> }
>
Powered by blists - more mailing lists