[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZZvWgXCxrBcVwFco@gmail.com>
Date: Mon, 8 Jan 2024 12:03:29 +0100
From: Ingo Molnar <mingo@...nel.org>
To: Linus Torvalds <torvalds@...ux-foundation.org>
Cc: linux-kernel@...r.kernel.org, the arch/x86 maintainers <x86@...nel.org>,
Vegard Nossum <vegard.nossum@...cle.com>
Subject: [GIT PULL] x86/asm changes for v6.8
Linus,
Please pull the latest x86/asm git tree from:
git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git x86-asm-2024-01-08
# HEAD: bc90aefa99f74452d549d503a3f1cbf3adc9c6bb x86/asm: Add DB flag to 32-bit percpu GDT entry
x86/asm changes for v6.8:
- Replace magic numbers in GDT descriptor definitions & handling:
- Introduce symbolic names via macros for descriptor types/fields/flags,
and then use these symbolic names.
- Clean up definitions a bit, such as GDT_ENTRY_INIT()
- Fix/clean up details that became visibly inconsistent after the
symbol-based code was introduced:
- Unify accessed flag handling
- Set the D/B size flag consistently & according to the HW specification
Thanks,
Ingo
------------------>
Vegard Nossum (5):
x86/asm: Provide new infrastructure for GDT descriptors
x86/asm: Replace magic numbers in GDT descriptors, preparations
x86/asm: Replace magic numbers in GDT descriptors, script-generated change
x86/asm: Always set A (accessed) flag in GDT descriptors
x86/asm: Add DB flag to 32-bit percpu GDT entry
arch/x86/boot/pm.c | 7 +--
arch/x86/include/asm/desc_defs.h | 78 +++++++++++++++++++++++++++------
arch/x86/kernel/apm_32.c | 2 +-
arch/x86/kernel/cpu/common.c | 48 +++++++++-----------
arch/x86/kernel/head64.c | 6 +--
arch/x86/kernel/setup_percpu.c | 4 +-
arch/x86/platform/pvh/head.S | 7 +--
arch/x86/realmode/rm/reboot.S | 3 +-
drivers/firmware/efi/libstub/x86-5lvl.c | 4 +-
drivers/pnp/pnpbios/bioscalls.c | 2 +-
10 files changed, 104 insertions(+), 57 deletions(-)
Powered by blists - more mailing lists