[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <9413ee17-70d6-4c27-ad8c-2cd4e0f7bb0b@redhat.com>
Date: Mon, 8 Jan 2024 18:18:53 +0100
From: Danilo Krummrich <dakr@...hat.com>
To: yang.guang5@....com.cn
Cc: jiang.xuexin@....com.cn, chen.haonan2@....com.cn, cgel.zte@...il.com,
lyude@...hat.com, airlied@...il.com, daniel@...ll.ch, bskeggs@...hat.com,
keescook@...omium.org, dri-devel@...ts.freedesktop.org,
nouveau@...ts.freedesktop.org, linux-kernel@...r.kernel.org,
kherbst@...hat.com
Subject: Re: [PATCH linux-next] drm/nouveau/disp: switch to use kmemdup()
helper
Hi Yang,
On 12/14/23 13:03, yang.guang5@....com.cn wrote:
> From: Yang Guang <yang.guang5@....com.cn>
>
> Use kmemdup() helper instead of open-coding to
> simplify the code.
>
> Signed-off-by: Chen Haonan <chen.haonan2@....com.cn>
Please add your "Signed-off-by" tag to this patch. If the above is intended to indicate
that Chan was involved in creating this patch (e.g. as co-author, reporter, etc.) please
use the corresponding tag instead. See also [1].
Once this is fixed, I'll apply the patch.
- Danilo
[1] https://www.kernel.org/doc/html/v4.17/process/submitting-patches.html#sign-your-work-the-developer-s-certificate-of-origin
> ---
> drivers/gpu/drm/nouveau/nvif/outp.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/nouveau/nvif/outp.c b/drivers/gpu/drm/nouveau/nvif/outp.c
> index 5d3190c05250..6daeb7f0b09b 100644
> --- a/drivers/gpu/drm/nouveau/nvif/outp.c
> +++ b/drivers/gpu/drm/nouveau/nvif/outp.c
> @@ -452,13 +452,12 @@ nvif_outp_edid_get(struct nvif_outp *outp, u8 **pedid)
> if (ret)
> goto done;
>
> - *pedid = kmalloc(args->size, GFP_KERNEL);
> + *pedid = kmemdup(args->data, args->size, GFP_KERNEL);
> if (!*pedid) {
> ret = -ENOMEM;
> goto done;
> }
>
> - memcpy(*pedid, args->data, args->size);
> ret = args->size;
> done:
> kfree(args);
Powered by blists - more mailing lists