lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Wed, 10 Jan 2024 20:13:31 +0900
From: Takashi Sakamoto <o-takashi@...amocchi.jp>
To: torvalds@...ux-foundation.org
Cc: linux-kernel@...r.kernel.org
Subject: [GIT PULL] firewire updates for 6.8

Hi Linus,

The following changes since commit 0dd3ee31125508cd67f7e7172247f05b7fd1753a:

  Linux 6.7 (2024-01-07 12:18:38 -0800)

are available in the Git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/ieee1394/linux1394.git tags/firewire-updates-6.8

for you to fetch changes up to 986c20bb3e67d0171c0c2e4acd25429b1876b963:

  firewire: core: fill model field in modalias of unit device for legacy layout of configuration ROM (2024-01-10 18:37:13 +0900)

----------------------------------------------------------------
firewire updates for 6.8

This update includes the series of changes related to device attributes,
as well as slight code refactoring.

Some old devices are recognized to have legacy layout of configuration ROM.
They have an inconvenience that FireWire subsystem adds no attributes for
vendor information to corresponding devices. The main purpose of this
update is to rectify the inconvenience.

We have a slight concern about regression. The update changes the value of
modalias for the unit devices by populating its model field, which was
previously left as zero in the case. I've assessed the potential impact of
this change and anticipate it to have minimal concern for both the kernel
and user lands. The change is enough acceptable.

----------------------------------------------------------------
Greg Kroah-Hartman (1):
      firewire: make fw_bus_type const

Takashi Sakamoto (8):
      firewire: core: adds constant qualifier for local helper functions
      firewire: core: replace magic number with macro
      firewire: test: add KUnit test for device attributes
      firewire: test: add test of device attributes for simple AV/C device
      firewire: test: add test of device attributes for legacy AV/C device
      firewire: core: detect numeric model identifier for legacy layout of configuration ROM
      firewire: core: detect model name for legacy layout of configuration ROM
      firewire: core: fill model field in modalias of unit device for legacy layout of configuration ROM

 drivers/firewire/.kunitconfig            |   1 +
 drivers/firewire/Kconfig                 |  16 +++++++++++++
 drivers/firewire/core-device.c           | 129 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++----------------------
 drivers/firewire/device-attribute-test.c | 251 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 include/linux/firewire.h                 |   2 +-
 5 files changed, 370 insertions(+), 29 deletions(-)
 create mode 100644 drivers/firewire/device-attribute-test.c


Regards

Takashi Sakamoto

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ