[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20240119132032.106053-3-abbotti@mev.co.uk>
Date: Fri, 19 Jan 2024 13:20:18 +0000
From: Ian Abbott <abbotti@....co.uk>
To: Matt Hsiao <matt.hsiao@....com>
Cc: Arnd Bergmann <arnd@...db.de>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
linux-kernel@...r.kernel.org,
Ian Abbott <abbotti@....co.uk>
Subject: [PATCH 2/2] misc: hpilo: rename device creation loop variable
In `ilo_probe()`, the loop variable `minor` isn't really the minor
device number, it's the channel or slot number. Rename it to `slot` for
consistency.
Signed-off-by: Ian Abbott <abbotti@....co.uk>
---
drivers/misc/hpilo.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/misc/hpilo.c b/drivers/misc/hpilo.c
index 3428a0bd5550..04bd34c8c506 100644
--- a/drivers/misc/hpilo.c
+++ b/drivers/misc/hpilo.c
@@ -770,7 +770,7 @@ static void ilo_remove(struct pci_dev *pdev)
static int ilo_probe(struct pci_dev *pdev,
const struct pci_device_id *ent)
{
- int devnum, minor, start, error = 0;
+ int devnum, slot, start, error = 0;
struct ilo_hwinfo *ilo_hw;
if (pci_match_id(ilo_blacklist, pdev)) {
@@ -839,11 +839,11 @@ static int ilo_probe(struct pci_dev *pdev,
goto remove_isr;
}
- for (minor = 0 ; minor < max_ccb; minor++) {
+ for (slot = 0; slot < max_ccb; slot++) {
struct device *dev;
dev = device_create(&ilo_class, &pdev->dev,
- MKDEV(ilo_major, start + minor), NULL,
- "hpilo!d%dccb%d", devnum, minor);
+ MKDEV(ilo_major, start + slot), NULL,
+ "hpilo!d%dccb%d", devnum, slot);
if (IS_ERR(dev))
dev_err(&pdev->dev, "Could not create files\n");
}
--
2.43.0
Powered by blists - more mailing lists