[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <b21d9eb5-eeb7-460f-99c1-9878532be148@embeddedor.com>
Date: Mon, 22 Jan 2024 11:51:49 -0600
From: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
To: Erick Archer <erick.archer@....com>,
Michael Turquette <mturquette@...libre.com>, Stephen Boyd
<sboyd@...nel.org>, Conor Dooley <conor.dooley@...rochip.com>,
Heiko Stuebner <heiko@...ech.de>, Dinh Nguyen <dinguyen@...nel.org>,
Rob Herring <robh@...nel.org>, Nick Alcock <nick.alcock@...cle.com>,
Uwe Kleine-König <u.kleine-koenig@...gutronix.de>,
"Gustavo A. R. Silva" <gustavoars@...nel.org>
Cc: linux-clk@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-hardening@...r.kernel.org
Subject: Re: [PATCH] clk: hisilicon: Use devm_kcalloc() instead of
devm_kzalloc()
On 1/21/24 08:29, Erick Archer wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the purpose specific devm_kcalloc() function instead of the
> argument size * count in the devm_kzalloc() function.
>
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162
> Signed-off-by: Erick Archer <erick.archer@....com>
Reviewed-by: Gustavo A. R. Silva <gustavoars@...nel.org>
Thanks!
--
Gustavo
> ---
> drivers/clk/hisilicon/clk-hi3559a.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/clk/hisilicon/clk-hi3559a.c b/drivers/clk/hisilicon/clk-hi3559a.c
> index ff4ca0edce06..da476f940326 100644
> --- a/drivers/clk/hisilicon/clk-hi3559a.c
> +++ b/drivers/clk/hisilicon/clk-hi3559a.c
> @@ -461,8 +461,7 @@ static void hisi_clk_register_pll(struct hi3559av100_pll_clock *clks,
> struct clk_init_data init;
> int i;
>
> - p_clk = devm_kzalloc(dev, sizeof(*p_clk) * nums, GFP_KERNEL);
> -
> + p_clk = devm_kcalloc(dev, nums, sizeof(*p_clk), GFP_KERNEL);
> if (!p_clk)
> return;
>
> --
> 2.25.1
>
>
Powered by blists - more mailing lists