[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <0705c04e-eebd-4402-b4ed-10a8e28fde17@loongson.cn>
Date: Tue, 23 Jan 2024 09:30:34 +0800
From: Yanteng Si <siyanteng@...ngson.cn>
To: Hu Haowen <2023002089@...k.tyut.edu.cn>,
Erick Archer <erick.archer@....com>, Viresh Kumar <vireshk@...nel.org>,
Nishanth Menon <nm@...com>, Stephen Boyd <sboyd@...nel.org>,
"Rafael J. Wysocki" <rafael@...nel.org>, Len Brown <len.brown@...el.com>,
Pavel Machek <pavel@....cz>, Alex Shi <alexs@...nel.org>,
Jonathan Corbet <corbet@....net>, "Gustavo A. R. Silva"
<gustavoars@...nel.org>
Cc: linux-pm@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-doc@...r.kernel.org, linux-hardening@...r.kernel.org
Subject: Re: [PATCH v2] Documentation: power: Use kcalloc() instead of
kzalloc()
在 2024/1/23 01:11, Hu Haowen 写道:
>
> 在 2024/1/21 18:43, Erick Archer 写道:
>> As noted in the "Deprecated Interfaces, Language Features, Attributes,
>> and Conventions" documentation [1], size calculations (especially
>> multiplication) should not be performed in memory allocator (or similar)
>> function arguments due to the risk of them overflowing. This could lead
>> to values wrapping around and a smaller allocation being made than the
>> caller was expecting. Using those allocations could lead to linear
>> overflows of heap memory and other misbehaviors.
>>
>> So, in the example code use the purpose specific kcalloc() function
>> instead of the argument size * count in the kzalloc() function.
>>
>> At the same time, modify the translations accordingly.
>>
>> Link:
>> https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>> [1]
>> Link: https://github.com/KSPP/linux/issues/162
>> Signed-off-by: Erick Archer <erick.archer@....com>
>> ---
>> Hi,
>>
>> This patch is a merger of two previous ones [1] [2].
>> As Hu Haowen and Jonathan Corbet suggested, the translation change
>> only makes sense if the original file is modified. So, with this
>> v2 version the original file and the translations are modified at
>> the same time.
>>
>> [1]
>> https://lore.kernel.org/linux-hardening/20240120120527.3866-1-erick.archer@gmx.com/
>> [2]
>> https://lore.kernel.org/linux-hardening/20240120122204.4287-1-erick.archer@gmx.com/
>>
>> Thanks,
>> Erick
>> ---
>> Documentation/power/opp.rst | 2 +-
>> Documentation/translations/zh_CN/power/opp.rst | 2 +-
>> 2 files changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/Documentation/power/opp.rst b/Documentation/power/opp.rst
>> index a7c03c470980..1b7f1d854f14 100644
>> --- a/Documentation/power/opp.rst
>> +++ b/Documentation/power/opp.rst
>> @@ -305,7 +305,7 @@ dev_pm_opp_get_opp_count
>> {
>> /* Do things */
>> num_available = dev_pm_opp_get_opp_count(dev);
>> - speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL);
>> + speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL);
>> /* populate the table in increasing order */
>> freq = 0;
>> while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) {
>> diff --git a/Documentation/translations/zh_CN/power/opp.rst
>> b/Documentation/translations/zh_CN/power/opp.rst
>> index 8d6e3f6f6202..7470fa2d4c43 100644
>> --- a/Documentation/translations/zh_CN/power/opp.rst
>> +++ b/Documentation/translations/zh_CN/power/opp.rst
>> @@ -274,7 +274,7 @@ dev_pm_opp_get_opp_count
>> {
>> /* 做一些事情 */
>> num_available = dev_pm_opp_get_opp_count(dev);
>> - speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL);
>> + speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL);
>
>
> For the zh_CN translation,
>
> Reviewed-by: Hu Haowen <2023002089@...k.tyut.edu.cn>
Same here,
Reviewed-by: Yanteng Si <siyanteng@...ngson.cn>
Thanks,
Yanteng
>
>
> Thanks,
>
> Hu Haowen
>
>
>> /* 按升序填充表 */
>> freq = 0;
>> while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) {
>> --
>> 2.25.1
>>
>>
>>
Powered by blists - more mailing lists