[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <cover.1706610398.git.christophe.leroy@csgroup.eu>
Date: Tue, 30 Jan 2024 11:34:31 +0100
From: Christophe Leroy <christophe.leroy@...roup.eu>
To: Andrew Morton <akpm@...ux-foundation.org>,
Kees Cook <keescook@...omium.org>
Cc: Christophe Leroy <christophe.leroy@...roup.eu>,
Russell King <linux@...linux.org.uk>,
Catalin Marinas <catalin.marinas@....com>,
Will Deacon <will@...nel.org>,
Michael Ellerman <mpe@...erman.id.au>,
Nicholas Piggin <npiggin@...il.com>,
"Aneesh Kumar K.V" <aneesh.kumar@...nel.org>,
"Naveen N. Rao" <naveen.n.rao@...ux.ibm.com>,
Paul Walmsley <paul.walmsley@...ive.com>,
Palmer Dabbelt <palmer@...belt.com>,
Albert Ou <aou@...s.berkeley.edu>,
Heiko Carstens <hca@...ux.ibm.com>,
Vasily Gorbik <gor@...ux.ibm.com>,
Alexander Gordeev <agordeev@...ux.ibm.com>,
Christian Borntraeger <borntraeger@...ux.ibm.com>,
Sven Schnelle <svens@...ux.ibm.com>,
Gerald Schaefer <gerald.schaefer@...ux.ibm.com>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>,
Borislav Petkov <bp@...en8.de>,
Dave Hansen <dave.hansen@...ux.intel.com>,
x86@...nel.org,
"H. Peter Anvin" <hpa@...or.com>,
Andy Lutomirski <luto@...nel.org>,
Peter Zijlstra <peterz@...radead.org>,
linux-arm-kernel@...ts.infradead.org,
linux-kernel@...r.kernel.org,
linuxppc-dev@...ts.ozlabs.org,
linux-riscv@...ts.infradead.org,
linux-s390@...r.kernel.org,
linux-mm@...ck.org,
steven.price@....com,
Phong Tran <tranmanphong@...il.com>,
mark.rutland@....com,
Greg KH <greg@...ah.com>
Subject: [PATCH v2 0/5] mm: ptdump: Refactor CONFIG_DEBUG_WX and check_wx_pages debugfs attribute
Refer old discussion at https://lore.kernel.org/lkml/20200422152656.GF676@willie-the-truck/T/#m802eaf33efd6f8d575939d157301b35ac0d4a64f
And https://github.com/KSPP/linux/issues/35
This series refactors CONFIG_DEBUG_WX for the 5 architectures
implementing CONFIG_GENERIC_PTDUMP
First rename stuff in ARM which uses similar names while not
implementing CONFIG_GENERIC_PTDUMP.
Then define a generic version of debug_checkwx() that calls
ptdump_check_wx() when CONFIG_DEBUG_WX is set. Call it immediately
after calling mark_rodata_ro() instead of calling it at the end of
every mark_rodata_ro().
Then implement a debugfs attribute that can be used to trigger
a W^X test at anytime and regardless of CONFIG_DEBUG_WX
Changes in v2:
- Fixed a few build failures (patch 1 and 2)
- Added patch 4
- Make the attribute return SUCCESS/FAILURE as suggested by Heiko (patch 5)
Christophe Leroy (5):
arm: ptdump: Rename CONFIG_DEBUG_WX to CONFIG_ARM_DEBUG_WX
arm64, powerpc, riscv, s390, x86: ptdump: Refactor CONFIG_DEBUG_WX
powerpc,s390: ptdump: Define ptdump_check_wx() regardless of
CONFIG_DEBUG_WX
mm: ptdump: Have ptdump_check_wx() return bool
mm: ptdump: add check_wx_pages debugfs attribute
arch/arm/Kconfig.debug | 2 +-
arch/arm/configs/aspeed_g4_defconfig | 2 +-
arch/arm/configs/aspeed_g5_defconfig | 2 +-
arch/arm/include/asm/ptdump.h | 6 +++---
arch/arm/mm/init.c | 2 +-
arch/arm64/include/asm/ptdump.h | 7 -------
arch/arm64/mm/mmu.c | 2 --
arch/arm64/mm/ptdump.c | 11 ++++++++---
arch/powerpc/mm/mmu_decl.h | 6 ------
arch/powerpc/mm/pgtable_32.c | 4 ----
arch/powerpc/mm/pgtable_64.c | 3 ---
arch/powerpc/mm/ptdump/ptdump.c | 21 ++++++++++++++-------
arch/riscv/include/asm/ptdump.h | 22 ----------------------
arch/riscv/mm/init.c | 3 ---
arch/riscv/mm/ptdump.c | 12 ++++++++----
arch/s390/include/asm/ptdump.h | 14 --------------
arch/s390/mm/dump_pagetables.c | 21 +++++++++++----------
arch/s390/mm/init.c | 2 --
arch/x86/include/asm/pgtable.h | 5 ++---
arch/x86/mm/dump_pagetables.c | 20 ++++++++++++++------
arch/x86/mm/init_32.c | 2 --
arch/x86/mm/init_64.c | 2 --
include/linux/ptdump.h | 7 +++++++
init/main.c | 2 ++
mm/ptdump.c | 22 ++++++++++++++++++++++
25 files changed, 95 insertions(+), 107 deletions(-)
delete mode 100644 arch/riscv/include/asm/ptdump.h
delete mode 100644 arch/s390/include/asm/ptdump.h
--
2.43.0
Powered by blists - more mailing lists