[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240201081935.200031-1-chentao@kylinos.cn>
Date: Thu, 1 Feb 2024 16:19:35 +0800
From: Kunwu Chan <chentao@...inos.cn>
To: chuck.lever@...cle.com,
jlayton@...nel.org,
neilb@...e.de,
kolga@...app.com,
Dai.Ngo@...cle.com,
tom@...pey.com
Cc: linux-nfs@...r.kernel.org,
linux-kernel@...r.kernel.org,
Kunwu Chan <chentao@...inos.cn>
Subject: [PATCH] nfsd: Simplify the allocation of slab caches in nfsd_drc_slab_create
Use the new KMEM_CACHE() macro instead of direct kmem_cache_create
to simplify the creation of SLAB caches.
Make the code cleaner and more readable.
Signed-off-by: Kunwu Chan <chentao@...inos.cn>
---
fs/nfsd/nfscache.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/fs/nfsd/nfscache.c b/fs/nfsd/nfscache.c
index 5c1a4a0aa605..64ce0cc22197 100644
--- a/fs/nfsd/nfscache.c
+++ b/fs/nfsd/nfscache.c
@@ -166,8 +166,7 @@ nfsd_reply_cache_free(struct nfsd_drc_bucket *b, struct nfsd_cacherep *rp,
int nfsd_drc_slab_create(void)
{
- drc_slab = kmem_cache_create("nfsd_drc",
- sizeof(struct nfsd_cacherep), 0, 0, NULL);
+ drc_slab = KMEM_CACHE(nfsd_cacherep, 0);
return drc_slab ? 0: -ENOMEM;
}
--
2.39.2
Powered by blists - more mailing lists