[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <51025C22-0FEF-4047-BC36-EA7ED7A3BD62@kernel.org>
Date: Mon, 05 Feb 2024 23:21:41 +0000
From: Kees Cook <kees@...nel.org>
To: Eric Biggers <ebiggers@...nel.org>, Kees Cook <keescook@...omium.org>
CC: linux-hardening@...r.kernel.org,
Rasmus Villemoes <rasmus.villemoes@...vas.dk>,
Mark Rutland <mark.rutland@....com>,
"Gustavo A. R. Silva" <gustavoars@...nel.org>,
Marco Elver <elver@...gle.com>, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v3 2/3] overflow: Introduce add_wrap(), sub_wrap(), and mul_wrap()
On February 5, 2024 11:17:12 PM GMT, Eric Biggers <ebiggers@...nel.org> wrote:
>On Mon, Feb 05, 2024 at 02:44:14PM -0800, Kees Cook wrote:
>> On Mon, Feb 05, 2024 at 12:21:45PM -0800, Eric Biggers wrote:
>> > On Mon, Feb 05, 2024 at 01:12:30AM -0800, Kees Cook wrote:
>> > > Subject: Re: [PATCH v3 2/3] overflow: Introduce add_wrap(), sub_wrap(), and mul_wrap()
>> >
>> > Maybe these should be called wrapping_add, wrapping_sub, and wrapping_mul?
>> > Those names are more grammatically correct, and Rust chose those names too.
>>
>> Sure, that works for me. What bout the inc_wrap() and dec_wrap() names?
>> I assume wrapping_inc() and wrapping_dec() ?
>>
>
>Yes, though I'm not sure those should exist at all. Maybe a += b should just
>become a = wrapping_add(a, b), instead of wrapping_inc(a, b)?
>wrapping_inc(a, b) isn't as self-explanatory. Likewise for wrapping_dec.
It was to avoid repeating type information, as it would go from:
var_a += var_b;
to:
var_a = wrapping_add(typeof(var_a), var_a, var_b);
Which repeats "var_a" 3 times. :|
--
Kees Cook
Powered by blists - more mailing lists