[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240205122916.it.909-kees@kernel.org>
Date: Mon, 5 Feb 2024 04:35:20 -0800
From: Kees Cook <keescook@...omium.org>
To: Andy Shevchenko <andy@...nel.org>
Cc: Kees Cook <keescook@...omium.org>,
Richard Weinberger <richard@....at>,
Justin Stitt <justinstitt@...gle.com>,
Anton Ivanov <anton.ivanov@...bridgegreys.com>,
Johannes Berg <johannes@...solutions.net>,
Willem de Bruijn <willemdebruijn.kernel@...il.com>,
Jason Wang <jasowang@...hat.com>,
kernel test robot <lkp@...el.com>,
Nathan Chancellor <nathan@...nel.org>,
Azeem Shaikh <azeemshaikh38@...il.com>,
linux-kernel@...r.kernel.org,
linux-hardening@...r.kernel.org,
linux-um@...ts.infradead.org
Subject: [PATCH v2 0/4] string: Allow 2-argument strscpy()
Hi,
v2:
- add strscpy_pad() coverage
- fix up ARCH=um to handle the renaming
- use __must_be_array() to validate sizeof() usage
v1: https://lore.kernel.org/all/20240131055340.work.279-kees@kernel.org/
Make it possible for strscpy() and strscpy_pad() to use 2 arguments,
making "sizeof(dst)" be the the default 3rd argument for the destination
size. This can make future usage much easier to read. Additionally allows
treewide changes to save a bunch of lines:
1177 files changed, 2455 insertions(+), 3026 deletions(-)
-Kees
Kees Cook (4):
string: Redefine strscpy_pad() as a macro
string: Allow 2-argument strscpy()
string: Allow 2-argument strscpy_pad()
um: Convert strscpy() usage to 2-argument style
arch/um/drivers/net_kern.c | 2 +-
arch/um/drivers/vector_kern.c | 2 +-
arch/um/drivers/vector_user.c | 4 +-
arch/um/include/shared/user.h | 3 +-
arch/um/os-Linux/drivers/ethertap_user.c | 2 +-
arch/um/os-Linux/drivers/tuntap_user.c | 2 +-
arch/um/os-Linux/umid.c | 6 +-
include/linux/fortify-string.h | 22 +------
include/linux/string.h | 75 +++++++++++++++++++++++-
lib/string.c | 4 +-
lib/string_helpers.c | 34 -----------
11 files changed, 87 insertions(+), 69 deletions(-)
--
2.34.1
Powered by blists - more mailing lists