[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240207-vbus-glitch-v1-2-7be87099461d@nxp.com>
Date: Wed, 07 Feb 2024 17:00:19 -0500
From: Frank Li <Frank.Li@....com>
To: Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Rob Herring <robh@...nel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
Conor Dooley <conor+dt@...nel.org>, Felipe Balbi <balbi@...nel.org>,
Thinh Nguyen <Thinh.Nguyen@...opsys.com>
Cc: linux-usb@...r.kernel.org, devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org, imx@...ts.linux.dev,
Frank Li <Frank.Li@....com>
Subject: [PATCH 2/2] usb: dwc3: drop 'quirk' suffix at
snps,host-vbus-glitches-quirk
Rename 'snps,host-vbus-glitches-quirk' to 'snps,host-vbus-glitches'.
Just describe the problem in the binding. So needn't 'quirk'. Software
implement is workaround, so keep variable name as
'host_vbus_glitches_quirk'.
Signed-off-by: Frank Li <Frank.Li@....com>
---
drivers/usb/dwc3/core.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/usb/dwc3/core.c b/drivers/usb/dwc3/core.c
index 3b68e8e45b8b9..2536b567efd56 100644
--- a/drivers/usb/dwc3/core.c
+++ b/drivers/usb/dwc3/core.c
@@ -1627,7 +1627,7 @@ static void dwc3_get_properties(struct dwc3 *dwc)
"snps,dis-split-quirk");
dwc->host_vbus_glitches_quirk = device_property_read_bool(dev,
- "snps,host-vbus-glitches-quirk");
+ "snps,host-vbus-glitches");
dwc->lpm_nyet_threshold = lpm_nyet_threshold;
dwc->tx_de_emphasis = tx_de_emphasis;
--
2.34.1
Powered by blists - more mailing lists