[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240208130424.59568-1-fabio.maria.de.francesco@linux.intel.com>
Date: Thu, 8 Feb 2024 14:04:22 +0100
From: "Fabio M. De Francesco" <fabio.maria.de.francesco@...ux.intel.com>
To: Peter Zijlstra <peterz@...radead.org>,
Dan Williams <dan.j.williams@...el.com>,
linux-kernel@...r.kernel.org
Cc: linux-cxl@...r.kernel.org,
Ingo Molnar <mingo@...nel.org>,
Dave Jiang <dave.jiang@...el.com>,
Jonathan Cameron <Jonathan.Cameron@...wei.com>,
Ira Weiny <ira.weiny@...el.com>,
"Fabio M. De Francesco" <fabio.maria.de.francesco@...ux.intel.com>
Subject: [PATCH 0/2 v4] Add cond_guard() to conditional guards
Add cond_guard() macro to conditional guards and use it to replace an
open-coded up_read() in show_targetN() and remove a block marked by an
'out' label.
Cc: Dave Jiang <dave.jiang@...el.com>
Cc: Jonathan Cameron <Jonathan.Cameron@...wei.com>
Cc: Peter Zijlstra <peterz@...radead.org>
Suggested-by: Dan Williams <dan.j.williams@...el.com>
Suggested-by: Ira Weiny <ira.weiny@...el.com>
Signed-off-by: Fabio M. De Francesco <fabio.maria.de.francesco@...ux.intel.com>
---
Changes from RFC v4:
Changed the interface of cond_guard() to take a variable to store
a return code, the succes code and failure code, to enable a
later check of the returned code in that variable.
Changes from RFC v5:
Changed the interface of cond_guard() to take a statement or
statement-expression as its second argument to conform to Dan's
suggestion (thanks).
Changes from v1:
Fixed a grammar error in the commit message of 1/2; replaced the
name of the second argument of cond_guard() with '_fail'
according to Jonathan's comments (thanks).
Changes from v2:
Changed macro's implementation to add an 'else' to protect
against it being used incorrectly within another if() block.
Suggested by Dan (thanks). The Reviewed-by tags on 1/2 are not
forwarded because the implementation of cond_guard() has changed.
Removed a redundant 'else' from show_targetN() in 2/2.
Changes from v3:
Added braces around empty body in an 'else' statement in
cond_guard(). Added Reviewed-by tags (Dave, Ira - thanks).
Fabio M. De Francesco (2):
cleanup: Add cond_guard() to conditional guards
cxl/region: Use cond_guard() in show_targetN()
drivers/cxl/core/region.c | 16 ++++------------
include/linux/cleanup.h | 15 +++++++++++++++
2 files changed, 19 insertions(+), 12 deletions(-)
--
2.43.0
Powered by blists - more mailing lists