[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <9c542f39-959e-4ab1-94a5-39e049a30743@xen.org>
Date: Wed, 14 Feb 2024 15:21:05 +0000
From: Paul Durrant <xadimgnik@...il.com>
To: Sean Christopherson <seanjc@...gle.com>
Cc: Paolo Bonzini <pbonzini@...hat.com>, Jonathan Corbet <corbet@....net>,
Thomas Gleixner <tglx@...utronix.de>, Ingo Molnar <mingo@...hat.com>,
Borislav Petkov <bp@...en8.de>, Dave Hansen <dave.hansen@...ux.intel.com>,
x86@...nel.org, "H. Peter Anvin" <hpa@...or.com>,
David Woodhouse <dwmw2@...radead.org>, Shuah Khan <shuah@...nel.org>,
kvm@...r.kernel.org, linux-doc@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-kselftest@...r.kernel.org,
Christian Borntraeger <borntraeger@...ux.ibm.com>,
Janosch Frank <frankja@...ux.ibm.com>,
Claudio Imbrenda <imbrenda@...ux.ibm.com>,
David Hildenbrand <david@...hat.com>
Subject: Re: [PATCH v12 08/20] KVM: pfncache: allow a cache to be activated
with a fixed (userspace) HVA
On 07/02/2024 04:03, Sean Christopherson wrote:
> +s390 folks (question on kvm_is_error_gpa() for ya)
>
> On Mon, Jan 15, 2024, Paul Durrant wrote:
>> @@ -1398,7 +1414,9 @@ void kvm_gpc_deactivate(struct gfn_to_pfn_cache *gpc);
>> static inline void kvm_gpc_mark_dirty(struct gfn_to_pfn_cache *gpc)
>> {
>> lockdep_assert_held(&gpc->lock);
>> - mark_page_dirty_in_slot(gpc->kvm, gpc->memslot, gpc->gpa >> PAGE_SHIFT);
>> +
>> + if (gpc->gpa != KVM_XEN_INVALID_GPA)
>
> KVM_XEN_INVALID_GPA absolutely doesn't belong in common code. Not to mention
> that it will break when Paolo (rightly) moves it to an x86 header.
>
> https://lore.kernel.org/all/20240131233056.10845-3-pbonzini@redhat.com
>
>> + mark_page_dirty_in_slot(gpc->kvm, gpc->memslot, gpc->gpa >> PAGE_SHIFT);
>> }
>>
>> void kvm_sigset_activate(struct kvm_vcpu *vcpu);
>> diff --git a/virt/kvm/pfncache.c b/virt/kvm/pfncache.c
>> index 97eec8ee3449..ae822bff812f 100644
>> --- a/virt/kvm/pfncache.c
>> +++ b/virt/kvm/pfncache.c
>> @@ -48,7 +48,10 @@ bool kvm_gpc_check(struct gfn_to_pfn_cache *gpc, unsigned long len)
>> if (!gpc->active)
>> return false;
>>
>> - if (gpc->generation != slots->generation || kvm_is_error_hva(gpc->uhva))
>> + if (gpc->gpa != KVM_XEN_INVALID_GPA && gpc->generation != slots->generation)
>
> This needs a comment. I know what it's doing, but it wasn't obvious at first
> glance, and it definitely won't be intuitive for readers that aren't intimately
> familiar with memslots.
>
>> + return false;
>> +
>> + if (kvm_is_error_hva(gpc->uhva))
>> return false;
>>
>> if (offset_in_page(gpc->uhva) + len > PAGE_SIZE)
>> @@ -209,11 +212,13 @@ static kvm_pfn_t hva_to_pfn_retry(struct gfn_to_pfn_cache *gpc)
>> return -EFAULT;
>> }
>>
>> -static int __kvm_gpc_refresh(struct gfn_to_pfn_cache *gpc, gpa_t gpa,
>> +static int __kvm_gpc_refresh(struct gfn_to_pfn_cache *gpc, gpa_t gpa, unsigned long uhva,
>> unsigned long len)
>> {
>> struct kvm_memslots *slots = kvm_memslots(gpc->kvm);
>> - unsigned long page_offset = offset_in_page(gpa);
>> + unsigned long page_offset = (gpa != KVM_XEN_INVALID_GPA) ?
>> + offset_in_page(gpa) :
>> + offset_in_page(uhva);
>
> This formatting is funky. I also think it would be worth adding a helper to pair
> with kvm_is_error_hva().
>
> But! kvm_is_error_gpa() already exists, and it very, very sneakily does a memslot
> lookup and checks for a valid HVA.
>
> s390 people, any objection to renaming kvm_is_error_gpa() to something like
> kvm_gpa_has_memslot() or kvm_gpa_is_in_memslot()? s390 is the only code that
> uses the existing helper.
>
> That would both to free up the name to pair with kvm_is_error_hva(), and would
> make it obvious what the helper does; I was quite surprised that "error" means
> "is covered by a valid memslot".
>
Seemingly no response to this; I'll define a local helper rather than
re-working the open-coded tests to check against INVALID_GPA. This can
then be trivially replaced if need be.
> Back to this code, then we can have a slightly cleaner:
>
> unsigned long page_offset = kvm_is_error_gpa(gpa) ? offset_in_page(gpa) :
> offset_in_page(uhva);
>
>
> And I think it's worth asserting that exactly _one_ of GPA or HVA is valid, e.g.
> to ensure KVM doesn't end up with botched offsets, and to make it a bit more
> clear what's going on.
>
>
> if (WARN_ON_ONCE(kvm_is_error_gpa(gpa) == kvm_is_error_hva(uhva))
> return -EINVAL;
Sure.
Powered by blists - more mailing lists