lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Fri, 16 Feb 2024 16:55:10 +1300
From: Barry Song <21cnbao@...il.com>
To: Nhat Pham <nphamcs@...il.com>
Cc: herbert@...dor.apana.org.au, davem@...emloft.net, 
	akpm@...ux-foundation.org, ddstreet@...e.org, sjenning@...hat.com, 
	vitaly.wool@...sulko.com, linux-crypto@...r.kernel.org, chriscli@...gle.com, 
	chrisl@...nel.org, hannes@...xchg.org, linux-kernel@...r.kernel.org, 
	linux-mm@...ck.org, yosryahmed@...gle.com, zhouchengming@...edance.com, 
	Barry Song <v-songbaohua@...o.com>
Subject: Re: [PATCH 2/3] mm/zswap: remove the memcpy if acomp is not asynchronous

On Thu, Jan 4, 2024 at 1:38 PM Nhat Pham <nphamcs@...il.com> wrote:
>
> On Wed, Jan 3, 2024 at 1:50 AM Barry Song <21cnbao@...il.com> wrote:
> >
> > From: Barry Song <v-songbaohua@...o.com>
> >
> > Most compressors are actually CPU-based and won't sleep during
> > compression and decompression. We should remove the redundant
> > memcpy for them.
> >
> > Signed-off-by: Barry Song <v-songbaohua@...o.com>
> > Tested-by: Chengming Zhou <zhouchengming@...edance.com>
>

Hi Nhat,
Thanks for reviewing!

> nit: it might help to include the test numbers in the changelog in
> this patch here too. Save a couple of clicks to dig out the original
> patch cover for the numbers :)

Chengming's test data is for the whole series. so i can't find the
proper commit to put the data. but it seems Andrew does have
a good habit to collect some important cover-letter info to commits,
so in v2, i'd keep the commit message as is.

>
> > ---
> >  mm/zswap.c | 6 ++++--
> >  1 file changed, 4 insertions(+), 2 deletions(-)
> >
> > diff --git a/mm/zswap.c b/mm/zswap.c
> > index ca25b676048e..36898614ebcc 100644
> > --- a/mm/zswap.c
> > +++ b/mm/zswap.c
> > @@ -168,6 +168,7 @@ struct crypto_acomp_ctx {
> >         struct crypto_wait wait;
> >         u8 *buffer;
> >         struct mutex mutex;
> > +       bool is_async; /* if acomp can sleep */
>
> nit: seems like this comment isn't necessary. is_async is pretty
> self-explanatory to me. But definitely not a show stopper tho :)

Thanks. I am changing the name to is_sleepable according to
Yosry's suggestion. As a result, the comment is removed as well.

>
> >  };
> >
> >  /*
> > @@ -716,6 +717,7 @@ static int zswap_cpu_comp_prepare(unsigned int cpu, struct hlist_node *node)
> >                 goto acomp_fail;
> >         }
> >         acomp_ctx->acomp = acomp;
> > +       acomp_ctx->is_async = acomp_is_async(acomp);
> >
> >         req = acomp_request_alloc(acomp_ctx->acomp);
> >         if (!req) {
> > @@ -1370,7 +1372,7 @@ static void __zswap_load(struct zswap_entry *entry, struct page *page)
> >         mutex_lock(&acomp_ctx->mutex);
> >
> >         src = zpool_map_handle(zpool, entry->handle, ZPOOL_MM_RO);
> > -       if (!zpool_can_sleep_mapped(zpool)) {
> > +       if (acomp_ctx->is_async && !zpool_can_sleep_mapped(zpool)) {
> >                 memcpy(acomp_ctx->buffer, src, entry->length);
> >                 src = acomp_ctx->buffer;
> >                 zpool_unmap_handle(zpool, entry->handle);
> > @@ -1384,7 +1386,7 @@ static void __zswap_load(struct zswap_entry *entry, struct page *page)
> >         BUG_ON(acomp_ctx->req->dlen != PAGE_SIZE);
> >         mutex_unlock(&acomp_ctx->mutex);
> >
> > -       if (zpool_can_sleep_mapped(zpool))
> > +       if (!acomp_ctx->is_async || zpool_can_sleep_mapped(zpool))
> >                 zpool_unmap_handle(zpool, entry->handle);
> >  }
> >
> > --
> > 2.34.1
> >
>
> The zswap side looks good to me. I don't have expertise/authority to
> ack the crypto API change (but FWIW it LGTM too based on a cursory
> code read).
> Reviewed-by: Nhat Pham <nphamcs@...il.com>

Thanks!
Barry

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ