[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240218133851.22c22b55460e866a099be5ce@linux-foundation.org>
Date: Sun, 18 Feb 2024 13:38:51 -0800
From: Andrew Morton <akpm@...ux-foundation.org>
To: Donet Tom <donettom@...ux.ibm.com>
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org, Aneesh Kumar
<aneesh.kumar@...nel.org>, Huang Ying <ying.huang@...el.com>, Dave Hansen
<dave.hansen@...ux.intel.com>, Mel Gorman <mgorman@...e.de>, Ben Widawsky
<ben.widawsky@...el.com>, Feng Tang <feng.tang@...el.com>, Michal Hocko
<mhocko@...nel.org>, Andrea Arcangeli <aarcange@...hat.com>, Peter Zijlstra
<peterz@...radead.org>, Ingo Molnar <mingo@...hat.com>, Rik van Riel
<riel@...riel.com>, Johannes Weiner <hannes@...xchg.org>, Matthew Wilcox
<willy@...radead.org>, Mike Kravetz <mike.kravetz@...cle.com>, Vlastimil
Babka <vbabka@...e.cz>, Dan Williams <dan.j.williams@...el.com>, Hugh
Dickins <hughd@...gle.com>, Kefeng Wang <wangkefeng.wang@...wei.com>, Suren
Baghdasaryan <surenb@...gle.com>
Subject: Re: [PATCH 1/3] mm/mempolicy: Use the already fetched local
variable
On Sat, 17 Feb 2024 01:31:33 -0600 Donet Tom <donettom@...ux.ibm.com> wrote:
> Avoid doing a per cpu read and use the local variable thisnid. IMHO
> this also makes the code more readable.
>
> ...
>
> --- a/mm/mempolicy.c
> +++ b/mm/mempolicy.c
> @@ -2526,7 +2526,7 @@ int mpol_misplaced(struct folio *folio, struct vm_area_struct *vma,
> if (node_isset(curnid, pol->nodes))
> goto out;
> z = first_zones_zonelist(
> - node_zonelist(numa_node_id(), GFP_HIGHUSER),
> + node_zonelist(thisnid, GFP_HIGHUSER),
> gfp_zone(GFP_HIGHUSER),
> &pol->nodes);
> polnid = zone_to_nid(z->zone);
int thisnid = cpu_to_node(thiscpu);
Is there any dofference between numa_node_id() and
cpu_to_node(raw_smp_processor_id())? And it it explicable that we're
using one here and not the other?
Powered by blists - more mailing lists