lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Wed, 21 Feb 2024 12:36:09 -0800
From: Andrew Morton <akpm@...ux-foundation.org>
To: Barry Song <21cnbao@...il.com>
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org, Barry Song
 <v-songbaohua@...o.com>
Subject: Re: [PATCH] mm/swapfile:__swap_duplicate: drop redundant WRITE_ONCE
 on swap_map for err cases

On Wed, 21 Feb 2024 22:10:28 +1300 Barry Song <21cnbao@...il.com> wrote:

> From: Barry Song <v-songbaohua@...o.com>
> 
> The code is quite hard to read, we are still writing swap_map after
> errors happen. Though the written value is as before,
> 
>  has_cache = count & SWAP_HAS_CACHE;
>  count &= ~SWAP_HAS_CACHE;
>  [snipped]
>  WRITE_ONCE(p->swap_map[offset], count | has_cache);
> 
> It would be better to entirely drop the WRITE_ONCE for both
> performance and readability.
> 
> ...
>
> --- a/mm/swapfile.c
> +++ b/mm/swapfile.c
> @@ -3320,6 +3320,9 @@ static int __swap_duplicate(swp_entry_t entry, unsigned char usage)
>  	} else
>  		err = -ENOENT;			/* unused swap entry */
>  
> +	if (err)
> +		goto unlock_out;
> +
>  	WRITE_ONCE(p->swap_map[offset], count | has_cache);
>  
>  unlock_out:

I agree, but why add the goto?

--- a/mm/swapfile.c~mm-swapfile-__swap_duplicate-drop-redundant-write_once-on-swap_map-for-err-cases-fix
+++ a/mm/swapfile.c
@@ -3335,10 +3335,8 @@ static int __swap_duplicate(swp_entry_t
 	} else
 		err = -ENOENT;			/* unused swap entry */
 
-	if (err)
-		goto unlock_out;
-
-	WRITE_ONCE(p->swap_map[offset], count | has_cache);
+	if (!err)
+		WRITE_ONCE(p->swap_map[offset], count | has_cache);
 
 unlock_out:
 	unlock_cluster_or_swap_info(p, ci);
_


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ