[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240221210845.13488-1-21cnbao@gmail.com>
Date: Thu, 22 Feb 2024 10:08:45 +1300
From: Barry Song <21cnbao@...il.com>
To: akpm@...ux-foundation.org,
linux-mm@...ck.org
Cc: linux-kernel@...r.kernel.org,
Barry Song <v-songbaohua@...o.com>
Subject: [PATCH v2] mm/swapfile:__swap_duplicate: drop redundant WRITE_ONCE on swap_map for err cases
From: Barry Song <v-songbaohua@...o.com>
The code is quite hard to read, we are still writing swap_map after
errors happen. Though the written value is as before,
has_cache = count & SWAP_HAS_CACHE;
count &= ~SWAP_HAS_CACHE;
[snipped]
WRITE_ONCE(p->swap_map[offset], count | has_cache);
It would be better to entirely drop the WRITE_ONCE for both
performance and readability.
Signed-off-by: Barry Song <v-songbaohua@...o.com>
---
-v2: drop goto according to Andrew, Thanks!
mm/swapfile.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/mm/swapfile.c b/mm/swapfile.c
index 556ff7347d5f..7cb6d9a2d51d 100644
--- a/mm/swapfile.c
+++ b/mm/swapfile.c
@@ -3320,7 +3320,8 @@ static int __swap_duplicate(swp_entry_t entry, unsigned char usage)
} else
err = -ENOENT; /* unused swap entry */
- WRITE_ONCE(p->swap_map[offset], count | has_cache);
+ if (!err)
+ WRITE_ONCE(p->swap_map[offset], count | has_cache);
unlock_out:
unlock_cluster_or_swap_info(p, ci);
--
2.34.1
Powered by blists - more mailing lists