[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZdWNvolkfPCyMNj9@slm.duckdns.org>
Date: Tue, 20 Feb 2024 19:44:30 -1000
From: Tejun Heo <tj@...nel.org>
To: Xuewen Yan <xuewen.yan94@...il.com>
Cc: Xuewen Yan <xuewen.yan@...soc.com>, jiangshanlai@...il.com,
corbet@....net, paulmck@...nel.org, rdunlap@...radead.org,
peterz@...radead.org, yanjiewtw@...il.com,
linux-doc@...r.kernel.org, linux-kernel@...r.kernel.org,
ke.wang@...soc.com
Subject: Re: [PATCH] workqueue: Control the frequency of intensive warning
through cmdline
Hello,
On Wed, Feb 21, 2024 at 10:01:17AM +0800, Xuewen Yan wrote:
> cnt = atomic64_inc_return_relaxed(&ent->cnt);
> - if (cnt >= 4 && is_power_of_2(cnt))
> + if (cnt == wq_cpu_intensive_warning_nth ||
> + (cnt > wq_cpu_intensive_warning_nth && is_power_of_2(cnt)))
If we do this the nth name doesn't really make sense. Maybe something like
wq_cpu_intensive_warning_thresh is better? Also, something like the
following might be more predictable. Let's say
wq_cpu_intensive_warning_thresh of 0 disables the warnings and it's
initialized to 4 by default.
if (cnt >= wq_cpu_intensive_warning_thresh &&
is_power_of_2(cnt + 1 - wq_cpu_intensive_warning_thresh))
Thanks.
--
tejun
Powered by blists - more mailing lists