[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20240222154146.GA8949@willie-the-truck>
Date: Thu, 22 Feb 2024 15:41:47 +0000
From: Will Deacon <will@...nel.org>
To: Anna-Maria Behnsen <anna-maria@...utronix.de>
Cc: linux-kernel@...r.kernel.org, Andy Lutomirski <luto@...nel.org>,
Thomas Gleixner <tglx@...utronix.de>,
Vincenzo Frascino <vincenzo.frascino@....com>,
Catalin Marinas <catalin.marinas@....com>,
linux-arm-kernel@...ts.infradead.org
Subject: Re: [PATCH 05/10] arm64/vdso: Use generic union vdso_data_store
On Mon, Feb 19, 2024 at 04:39:34PM +0100, Anna-Maria Behnsen wrote:
> There is already a generic union definition for vdso_data_store in vdso
> datapage header.
>
> Use this definition to prevent code duplication.
>
> Signed-off-by: Anna-Maria Behnsen <anna-maria@...utronix.de>
> Cc: Catalin Marinas <catalin.marinas@....com>
> Cc: Will Deacon <will@...nel.org>
> Cc: linux-arm-kernel@...ts.infradead.org
> ---
> arch/arm64/kernel/vdso.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/arch/arm64/kernel/vdso.c b/arch/arm64/kernel/vdso.c
> index 5562daf38a22..89b6e7840002 100644
> --- a/arch/arm64/kernel/vdso.c
> +++ b/arch/arm64/kernel/vdso.c
> @@ -69,10 +69,7 @@ static struct vdso_abi_info vdso_info[] __ro_after_init = {
> /*
> * The vDSO data page.
> */
> -static union {
> - struct vdso_data data[CS_BASES];
> - u8 page[PAGE_SIZE];
> -} vdso_data_store __page_aligned_data;
> +static union vdso_data_store vdso_data_store __page_aligned_data;
> struct vdso_data *vdso_data = vdso_data_store.data;
>
> static int vdso_mremap(const struct vm_special_mapping *sm,
> --
> 2.39.2
Acked-by: Will Deacon <will@...nel.org>
Will
Powered by blists - more mailing lists