[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <1e3b71a7-1515-4533-a102-34509f8b2f01@linux.intel.com>
Date: Mon, 26 Feb 2024 14:09:26 +0800
From: Baolu Lu <baolu.lu@...ux.intel.com>
To: Erick Archer <erick.archer@....com>, David Woodhouse
<dwmw2@...radead.org>, Joerg Roedel <joro@...tes.org>,
Will Deacon <will@...nel.org>, Robin Murphy <robin.murphy@....com>,
"Gustavo A. R. Silva" <gustavoars@...nel.org>,
Kees Cook <keescook@...omium.org>
Cc: baolu.lu@...ux.intel.com, iommu@...ts.linux.dev,
linux-kernel@...r.kernel.org, linux-hardening@...r.kernel.org
Subject: Re: [PATCH] iommu/vt-d: Use kcalloc() instead of kzalloc()
On 2/12/24 1:51 AM, Erick Archer wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1].
>
> Here the multiplication is obviously safe because DMAR_LATENCY_NUM
> is the number of latency types defined in the "latency_type" enum.
>
> enum latency_type {
> DMAR_LATENCY_INV_IOTLB = 0,
> DMAR_LATENCY_INV_DEVTLB,
> DMAR_LATENCY_INV_IEC,
> DMAR_LATENCY_PRQ,
> DMAR_LATENCY_NUM
> };
>
> However, using kcalloc() is more appropriate [2] and improves
> readability. This patch has no effect on runtime behavior.
>
> Link:https://github.com/KSPP/linux/issues/162 [1]
> Link:https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [2]
> Signed-off-by: Erick Archer<erick.archer@....com>
> ---
> drivers/iommu/intel/perf.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
I have queued this patch for v6.9.
Best regards,
baolu
Powered by blists - more mailing lists