[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240305214656.GA550701@bhelgaas>
Date: Tue, 5 Mar 2024 15:46:56 -0600
From: Bjorn Helgaas <helgaas@...nel.org>
To: linux-pci@...r.kernel.org
Cc: linux-kernel@...r.kernel.org,
Mika Westerberg <mika.westerberg@...ux.intel.com>,
"David E . Box" <david.e.box@...ux.intel.com>,
Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>,
"Rafael J . Wysocki" <rafael@...nel.org>,
Tasev Nikola <tasev.stefanoska@...net.be>,
Mark Enriquez <enriquezmark36@...il.com>,
Thomas Witt <kernel@...t.link>,
Werner Sembach <wse@...edocomputers.com>,
Vidya Sagar <vidyas@...dia.com>,
Kai-Heng Feng <kai.heng.feng@...onical.com>,
Kuppuswamy Sathyanarayanan <sathyanarayanan.kuppuswamy@...ux.intel.com>,
Ricky Wu <ricky_wu@...ltek.com>,
Mario Limonciello <mario.limonciello@....com>,
Bjorn Helgaas <bhelgaas@...gle.com>
Subject: Re: [PATCH v7 0/5] PCI/ASPM: Save/restore L1 PM Substates for
suspend/resume
On Fri, Feb 23, 2024 at 02:58:46PM -0600, Bjorn Helgaas wrote:
> From: Bjorn Helgaas <bhelgaas@...gle.com>
>
> This is some rework of David's series to preserve ASPM L1 substate
> configuration across suspend/resume.
>
> We've had several attempts to make this work:
>
> (unlabeled): https://lore.kernel.org/r/20240128233212.1139663-1-david.e.box@linux.intel.com
> v5: https://lore.kernel.org/r/20231221011250.191599-1-david.e.box@linux.intel.com
> v4: https://lore.kernel.org/all/20231002070044.2299644-1-mika.westerberg@linux.intel.com/
> v3: https://lore.kernel.org/linux-pci/20230925074636.2893747-1-mika.westerberg@linux.intel.com/
> v2: https://lore.kernel.org/linux-pci/20230911073352.3472918-1-mika.westerberg@linux.intel.com/
> v1: https://lore.kernel.org/linux-pci/20230627062442.54008-1-mika.westerberg@linux.intel.com/
>
> The most recent posting is the unlabeled one mentioned above, and I'm
> calling it v6 and this rework v7.
>
> Changes since the unlabeled v6:
>
> - Rename pci_save_aspm_state() to pci_save_aspm_l1ss_state() (this
> is the reason for opening this again, because Vidya's patch [1]
> had to do some incidental renaming).
>
> - Rename pcie_restore_aspm_l1ss() to pci_restore_aspm_l1ss_state()
> to match.
>
> - Move the PCI_EXP_LNKCTL_ASPMC from pci_restore_aspm_state() to
> pci_restore_pcie_state() so both writes are in the same place.
>
> - Rename pci_aspm_get_l1ss() to pci_configure_aspm_l1ss() and add
> the save_buffer there as well.
>
> - Split [1/5] into two patches: move pci_configure_ltr() and
> pci_bridge_reconfigure_ltr() to aspm.c, and build aspm.c
> unconditionally.
>
> - Squash [2/5] and [3/5] since [2/5] didn't add any functionality
> itself so they seem like a single logical change.
>
> [1] https://lore.kernel.org/r/20230125133830.20620-1-vidyas@nvidia.com
>
> David E. Box (5):
> PCI/ASPM: Move pci_configure_ltr() to aspm.c
> PCI/ASPM: Always build aspm.c
> PCI/ASPM: Move pci_save_ltr_state() to aspm.c
> PCI/ASPM: Save L1 PM Substates Capability for suspend/resume
> PCI/ASPM: Call pci_save_ltr_state() from pci_save_pcie_state()
>
> drivers/pci/pci.c | 89 ++++------------
> drivers/pci/pci.h | 13 ++-
> drivers/pci/pcie/Makefile | 2 +-
> drivers/pci/pcie/aspm.c | 215 ++++++++++++++++++++++++++++++++++++++
> drivers/pci/probe.c | 62 +----------
> include/linux/pci.h | 2 +-
> 6 files changed, 252 insertions(+), 131 deletions(-)
I applied these as pci/aspm for v6.9, replacing the original unlabeled
v6 that has been in -next.
I also added the patch I suggested at
https://lore.kernel.org/r/20240223213733.GA115410@bhelgaas to disable
L1 inside pci_restore_aspm_l1ss_state() where we actually depend on it
being disabled.
Bjorn
Powered by blists - more mailing lists