[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20240305090429.GA5206@google.com>
Date: Tue, 5 Mar 2024 09:04:29 +0000
From: Lee Jones <lee@...nel.org>
To: Abdel Alkuor <alkuor@...il.com>
Cc: Pavel Machek <pavel@....cz>, Rob Herring <robh+dt@...nel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
Conor Dooley <conor+dt@...nel.org>,
Alice Chen <alice_chen@...htek.com>,
Jean-Jacques Hiblot <jjhiblot@...phandler.com>,
ChiYuan Huang <cy_huang@...htek.com>,
ChiaEn Wu <chiaen_wu@...htek.com>,
Lukas Bulwahn <lukas.bulwahn@...il.com>,
André Apitzsch <git@...tzsch.eu>,
linux-leds@...r.kernel.org, devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 2/2] leds: Add NCP5623 multi-led driver
On Mon, 04 Mar 2024, Abdel Alkuor wrote:
> On Fri, Mar 01, 2024 at 08:50:46AM +0000, Lee Jones wrote:
>
> Hi Lee,
> > > +#define NCP5623_REG(x) ((x) << 0x5)
> >
> > What's 0x5? Probably worth defining.
> This is a function offset. I'll add a define.
>
> >
> > > + guard(mutex)(&ncp->lock);
> >
> > Are these self-unlocking?
> Correct. Here is a short introduction about it
> https://www.marcusfolkesson.se/blog/mutex-guards-in-the-linux-kernel/
Neat.
> > > + ncp->old_brightness = brightness;
> >
> > The nomenclature is confusing here.
> >
> > For the most part, this will carry the present value, no?
> >
> Yes, I'll change it to current_brightness instead
Just 'brightness' will be fine.
> > > + ret = ncp5623_write(ncp->client,
> > > + NCP5623_DIMMING_TIME_REG, pattern[0].delta_t / 8);
> >
> > Why 8? Magic numbers should be replaced with #defines.
> >
> This is dim step in ms. I'll add a define for it.
>
> > > +static int ncp5623_pattern_clear(struct led_classdev *led_cdev)
> > > +{
> > > + return 0;
> > > +}
> >
> > Not sure I see the point in this.
> >
> > Is the .pattern_clear() compulsorily?
> >
> Unfortunately, it is. For example, in pattern_trig_store_patterns, when
> hw pattern is used, it is expected to have pattern_clear implemented.
>
> static ssize_t pattern_trig_store_patterns(struct led_classdev *led_cdev,
> const char *buf, const u32 *buf_int,
> size_t count, bool hw_pattern)
> {
> ...
> if (data->is_hw_pattern)
> led_cdev->pattern_clear(led_cdev);
> ...
> }
Something's not right then. If this is required, are you sure you're
not meant to do something here? If there are times when this is not
required, it should be possible to omit it.
--
Lee Jones [李琼斯]
Powered by blists - more mailing lists