lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Mon, 11 Mar 2024 13:17:48 +0100
From: Ingo Molnar <mingo@...nel.org>
To: Linus Torvalds <torvalds@...ux-foundation.org>
Cc: linux-kernel@...r.kernel.org, Peter Zijlstra <peterz@...radead.org>,
	Thomas Gleixner <tglx@...utronix.de>,
	Juri Lelli <juri.lelli@...hat.com>,
	Vincent Guittot <vincent.guittot@...aro.org>,
	Dietmar Eggemann <dietmar.eggemann@....com>,
	Steven Rostedt <rostedt@...dmis.org>,
	Ben Segall <bsegall@...gle.com>, Mel Gorman <mgorman@...e.de>,
	Daniel Bristot de Oliveira <bristot@...hat.com>,
	Valentin Schneider <vschneid@...hat.com>,
	Shrikanth Hegde <sshegde@...ux.ibm.com>
Subject: [GIT PULL] Scheduler changes for v6.9

Linus,

Please pull the latest sched/core git tree from:

   git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git sched-core-2024-03-11

   # HEAD: 54de442747037485da1fc4eca9636287a61e97e3 sched/topology: Rename SD_SHARE_PKG_RESOURCES to SD_SHARE_LLC

Scheduler changes for v6.9:

 - Fix inconsistency in misfit task load-balancing

 - Fix CPU isolation bugs in the task-wakeup logic

 - Rework & unify the sched_use_asym_prio() and sched_asym_prefer() logic

 - Clean up & simplify ->avg_* accesses

 - Misc cleanups & fixes

 Thanks,

	Ingo

------------------>
Alex Shi (5):
      sched/topology: Remove duplicate descriptions from TOPOLOGY_SD_FLAGS
      sched/fair: Remove unused parameter from sched_asym()
      sched/fair: Rework sched_use_asym_prio() and sched_asym_prefer()
      sched/fair: Check the SD_ASYM_PACKING flag in sched_use_asym_prio()
      sched/topology: Rename SD_SHARE_PKG_RESOURCES to SD_SHARE_LLC

David Vernet (3):
      sched/fair: Remove unnecessary goto in update_sd_lb_stats()
      sched/fair: Do strict inequality check for busiest misfit task group
      sched/fair: Simplify the update_sd_pick_busiest() logic

Keisuke Nishimura (2):
      sched/fair: Take the scheduling domain into account in select_idle_smt()
      sched/fair: Take the scheduling domain into account in select_idle_core()

Shrikanth Hegde (3):
      sched/core: Simplify code by removing duplicate #ifdefs
      sched/fair: Use existing helper functions to access ->avg_rt and ->avg_dl
      sched/fair: Add READ_ONCE() and use existing helper function to access ->avg_irq


 arch/powerpc/kernel/smp.c      |   6 +--
 include/linux/sched/sd_flags.h |   4 +-
 include/linux/sched/topology.h |   6 +--
 kernel/sched/core.c            |   4 +-
 kernel/sched/fair.c            | 110 +++++++++++++++++------------------------
 kernel/sched/sched.h           |   2 +-
 kernel/sched/topology.c        |  35 ++++++-------
 7 files changed, 74 insertions(+), 93 deletions(-)

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ