lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Tue, 12 Mar 2024 06:53:09 +0000
From: "Song, Xiongwei" <Xiongwei.Song@...driver.com>
To: Chengming Zhou <chengming.zhou@...ux.dev>,
        "sxwjean@...com"
	<sxwjean@...com>, Christoph Lameter <cl@...ux.com>,
        Pekka Enberg
	<penberg@...nel.org>,
        David Rientjes <rientjes@...gle.com>,
        Joonsoo Kim
	<iamjoonsoo.kim@....com>,
        Andrew Morton <akpm@...ux-foundation.org>,
        Vlastimil Babka <vbabka@...e.cz>,
        Roman Gushchin <roman.gushchin@...ux.dev>,
        Hyeonggon Yoo <42.hyeyoo@...il.com>
CC: "linux-mm@...ck.org" <linux-mm@...ck.org>,
        "linux-kernel@...r.kernel.org"
	<linux-kernel@...r.kernel.org>
Subject: RE: [PATCH] mm/slub: Simplify get_partial_node()

> On 2024/3/11 21:27, sxwjean@...com wrote:
> > From: Xiongwei Song <xiongwei.song@...driver.com>
> >
> > Remove the check of !kmem_cache_has_cpu_partial() because it is always
> > false, we've known this by calling kmem_cache_debug() before calling
> > remove_partial(), so we can remove the check.
> 
> This is correct.
> 
> >
> > Meanwhile, redo filling cpu partial and add comment to improve the
> > readability.
> >
> > Signed-off-by: Xiongwei Song <xiongwei.song@...driver.com>
> > ---
> >  mm/slub.c | 22 ++++++++++++----------
> >  1 file changed, 12 insertions(+), 10 deletions(-)
> >
> > diff --git a/mm/slub.c b/mm/slub.c
> > index a3ab096c38c0..62388f2a0ac7 100644
> > --- a/mm/slub.c
> > +++ b/mm/slub.c
> > @@ -2620,19 +2620,21 @@ static struct slab *get_partial_node(struct
> kmem_cache *s,
> >               if (!partial) {
> >                       partial = slab;
> >                       stat(s, ALLOC_FROM_PARTIAL);
> > -             } else {
> > +
> > +                     /* Fill cpu partial if needed from next iteration, or break */
> > +                     if (IS_ENABLED(CONFIG_SLUB_CPU_PARTIAL))
> > +                             continue;
> > +                     else
> > +                             break;
> > +             }
> > +
> > +             if (IS_ENABLED(CONFIG_SLUB_CPU_PARTIAL)) {
> 
> But this won't work since "s->cpu_partial_slabs" is defined under
> CONFIG_SLUB_CPU_PARTIAL,
> you would get compiler error if building without CONFIG_SLUB_CPU_PARTIAL.

Yes, maybe we can use "#if IS_ENABLED(CONFIG_SLUB_CPU_PARTIAL)" instead.

Regards,
Xiongwei

> 
> Thanks.
> 
> >                       put_cpu_partial(s, slab, 0);
> >                       stat(s, CPU_PARTIAL_NODE);
> > -                     partial_slabs++;
> > -             }
> > -#ifdef CONFIG_SLUB_CPU_PARTIAL
> > -             if (!kmem_cache_has_cpu_partial(s)
> > -                     || partial_slabs > s->cpu_partial_slabs / 2)
> > -                     break;
> > -#else
> > -             break;
> > -#endif
> >
> > +                     if (++partial_slabs > s->cpu_partial_slabs/2)
> > +                             break;
> > +             }
> >       }
> >       spin_unlock_irqrestore(&n->list_lock, flags);
> >       return partial;

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ