[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <2c63a094-6966-7679-2b23-58c057b451d8@inria.fr>
Date: Wed, 13 Mar 2024 09:18:08 +0100 (CET)
From: Julia Lawall <julia.lawall@...ia.fr>
To: Ayush Tiwari <ayushtiw0110@...il.com>
cc: Larry.Finger@...inger.net, florian.c.schilhabel@...glemail.com,
gregkh@...uxfoundation.org, linux-kernel@...r.kernel.org,
linux-staging@...ts.linux.dev, outreachy@...ts.linux.dev
Subject: Re: [PATCH v4] staging: rtl8712: rename tmpVal to pct_val
On Wed, 13 Mar 2024, Ayush Tiwari wrote:
> Rename local variable tmpVal to pct_val in function process_link_qual
> to give intuitive meaning to variable and match the common kernel
> coding style.
I don't think that the patch with the name avg_val was accepted, so this
patch has to replace tmpVal by pct_val, as you say in the subject line.
Also, the comment says:
/* <1> Showed on UI for user, in percentage. */
I still have the impression that the value calculated here is an average.
Total num is just incremented:
if (sqd->total_num++ >= PHY_LINKQUALITY_SLID_WIN_MAX)
while total_val is updated with a new value.
julia
>
> Signed-off-by: Ayush Tiwari <ayushtiw0110@...il.com>
> ---
> Changes in v3: changed variable name avg_val to pct_val
> Changes in v3: changed variable name tmpVal to avg_val
> Changes in v2: added a period in message
>
> drivers/staging/rtl8712/rtl8712_recv.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/staging/rtl8712/rtl8712_recv.c b/drivers/staging/rtl8712/rtl8712_recv.c
> index 1fabc5137a4c..0b13d0a04304 100644
> --- a/drivers/staging/rtl8712/rtl8712_recv.c
> +++ b/drivers/staging/rtl8712/rtl8712_recv.c
> @@ -861,7 +861,7 @@ static void query_rx_phy_status(struct _adapter *padapter,
> static void process_link_qual(struct _adapter *padapter,
> union recv_frame *prframe)
> {
> - u32 last_evm = 0, avg_val;
> + u32 last_evm = 0, pct_val;
> struct rx_pkt_attrib *pattrib;
> struct smooth_rssi_data *sqd = &padapter->recvpriv.signal_qual_data;
>
> @@ -883,8 +883,8 @@ static void process_link_qual(struct _adapter *padapter,
> sqd->index = 0;
>
> /* <1> Showed on UI for user, in percentage. */
> - avg_val = sqd->total_val / sqd->total_num;
> - padapter->recvpriv.signal = (u8)avg_val;
> + pct_val = sqd->total_val / sqd->total_num;
> + padapter->recvpriv.signal = (u8)pct_val;
> }
> }
>
> --
> 2.40.1
>
>
>
Powered by blists - more mailing lists