[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240318-flocken-nagetiere-1e027955d06e@brauner>
Date: Mon, 18 Mar 2024 16:13:12 +0100
From: Christian Brauner <brauner@...nel.org>
To: Vinicius Costa Gomes <vinicius.gomes@...el.com>
Cc: amir73il@...il.com, hu1.chen@...el.com, miklos@...redi.hu,
malini.bhandaru@...el.com, tim.c.chen@...el.com, mikko.ylinen@...el.com,
lizhen.you@...el.com, linux-unionfs@...r.kernel.org, linux-fsdevel@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [RFC v3 1/5] cleanup: Fix discarded const warning when defining
lock guard
On Thu, Feb 15, 2024 at 09:16:36PM -0800, Vinicius Costa Gomes wrote:
> Fix the following warning when defining a cleanup guard for a "const"
> pointer type:
>
> ./include/linux/cleanup.h:211:18: warning: return discards ‘const’ qualifier from pointer target type [-Wdiscarded-qualifiers]
> 211 | return _T->lock; \
> | ~~^~~~~~
> ./include/linux/cleanup.h:233:1: note: in expansion of macro ‘__DEFINE_UNLOCK_GUARD’
> 233 | __DEFINE_UNLOCK_GUARD(_name, _type, _unlock, __VA_ARGS__) \
> | ^~~~~~~~~~~~~~~~~~~~~
> ./include/linux/cred.h:193:1: note: in expansion of macro ‘DEFINE_LOCK_GUARD_1’
> 193 | DEFINE_LOCK_GUARD_1(cred, const struct cred, _T->lock = override_creds_light(_T->lock),
> | ^~~~~~~~~~~~~~~~~~~
>
> Signed-off-by: Vinicius Costa Gomes <vinicius.gomes@...el.com>
> ---
> include/linux/cleanup.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/include/linux/cleanup.h b/include/linux/cleanup.h
> index c2d09bc4f976..085482ef46c8 100644
> --- a/include/linux/cleanup.h
> +++ b/include/linux/cleanup.h
> @@ -208,7 +208,7 @@ static inline void class_##_name##_destructor(class_##_name##_t *_T) \
> \
> static inline void *class_##_name##_lock_ptr(class_##_name##_t *_T) \
> { \
> - return _T->lock; \
> + return (void *)_T->lock; \
> }
I think both of these patches are a bit ugly as we burden the generic
cleanup code with casting to void which could cause actual issues.
Casting from const to non-const is rather specific to the cred code so I
would rather like to put the burden on the cred code instead of the
generic code if possible.
Powered by blists - more mailing lists