[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240325083105.658-1-petrtesarik@huaweicloud.com>
Date: Mon, 25 Mar 2024 09:31:03 +0100
From: Petr Tesarik <petrtesarik@...weicloud.com>
To: Christoph Hellwig <hch@....de>,
Marek Szyprowski <m.szyprowski@...sung.com>,
Robin Murphy <robin.murphy@....com>,
Petr Tesarik <petr.tesarik1@...wei-partners.com>,
Michael Kelley <mhklinux@...look.com>,
Will Deacon <will@...nel.org>,
linux-kernel@...r.kernel.org (open list),
iommu@...ts.linux.dev (open list:DMA MAPPING HELPERS)
Cc: Roberto Sassu <roberto.sassu@...weicloud.com>,
Petr Tesarik <petr@...arici.cz>
Subject: [PATCH v4 0/2] swiotlb: allocate padding slots if necessary
From: Petr Tesarik <petr.tesarik1@...wei-partners.com>
If the allocation alignment is bigger than IO_TLB_SIZE and min_align_mask
covers some bits in the original address between IO_TLB_SIZE and
alloc_align_mask, preserve these bits by allocating additional padding
slots before the actual swiotlb buffer.
Changes from v3
---------------
* Add a parameter to swiotlb_align_offset(), so it is not open-coded in
swiotlb_tbl_map_single().
* Extend the description of swiotlb_align_offset() and convert it to the
kernel-doc format.
* Use bit operations to calculate number of padding slots and the padding
inside a slot. This matches all other such calculations in swiotlb.c.
Changes from v2
---------------
* Fix assignment of an uninitialized variable to pad_slots.
* Improve commit message wrt INVALID_PHYS_ADDR.
Changes from v1
---------------
* Rename padding to pad_slots.
* Set pad_slots only for the first allocated non-padding slot.
* Do not bother initializing orig_addr to INVALID_PHYS_ADDR.
* Change list and pad_slots to unsigned short to avoid growing
struct io_tlb_slot on 32-bit targets.
* Add build-time check that list and pad_slots can hold the maximum
allowed value of IO_TLB_SEGSIZE.
Petr Tesarik (2):
swiotlb: extend buffer pre-padding to alloc_align_mask if necessary
bug: introduce ASSERT_VAR_CAN_HOLD()
include/linux/build_bug.h | 10 +++++++
kernel/dma/swiotlb.c | 61 ++++++++++++++++++++++++++++++---------
2 files changed, 58 insertions(+), 13 deletions(-)
--
2.34.1
Powered by blists - more mailing lists