[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240325223339.169350-1-vishal.moola@gmail.com>
Date: Mon, 25 Mar 2024 15:33:34 -0700
From: "Vishal Moola (Oracle)" <vishal.moola@...il.com>
To: linux-mm@...ck.org
Cc: linux-kernel@...r.kernel.org,
akpm@...ux-foundation.org,
muchun.song@...ux.dev,
"Vishal Moola (Oracle)" <vishal.moola@...il.com>
Subject: [PATCH 0/5] Define struct vm_fault in handle_mm_fault()
This patchset converts the hugetlb fault path to use struct vm_fault.
This helps make the code more readable, and alleviates the stack by
allowing us to consolidate many fault-related variables into an
individual pointer.
Defining the vm_fault in handle_mm_fault() and passing it to
hugetlb_fault() and __handle_mm_fault() has the additional benefit of
standardizing some variable names between hugetlbfs and the rest of mm
as well.
Vishal Moola (Oracle) (5):
hugetlb: Convert hugetlb_fault() to use struct vm_fault
hugetlb: Convert hugetlb_no_page() to use struct vm_fault
hugetlb: Convert hugetlb_wp() to use struct vm_fault
mm: Make pgoff non-const in struct vm_fault
memory: Define struct vm_fault in handle_mm_fault()
include/linux/hugetlb.h | 7 +-
include/linux/mm.h | 5 +-
mm/hugetlb.c | 228 +++++++++++++++++++---------------------
mm/memory.c | 87 +++++++--------
4 files changed, 160 insertions(+), 167 deletions(-)
--
2.43.0
Powered by blists - more mailing lists