[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAJD7tkb-mo-ote4PGa06mksrVEfQ=qANXGneAwLn4OMSfVJySA@mail.gmail.com>
Date: Wed, 27 Mar 2024 15:32:19 -0700
From: Yosry Ahmed <yosryahmed@...gle.com>
To: Chengming Zhou <chengming.zhou@...ux.dev>
Cc: Andrew Morton <akpm@...ux-foundation.org>, Johannes Weiner <hannes@...xchg.org>,
Nhat Pham <nphamcs@...il.com>, linux-mm@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [RFC PATCH 4/9] mm: zswap: move more same-filled pages checks
outside of zswap_store()
On Tue, Mar 26, 2024 at 7:39 PM Chengming Zhou <chengming.zhou@...ux.dev> wrote:
>
> On 2024/3/26 07:50, Yosry Ahmed wrote:
> > Currently, zswap_store() check zswap_same_filled_pages_enabled, kmaps
> > the folio, then calls zswap_is_page_same_filled() to check the folio
> > contents. Move this logic into zswap_is_page_same_filled() as well (and
> > rename it to use 'folio' while we are at it).
> >
> > This makes zswap_store() cleaner, and makes following changes to that
> > logic contained within the helper.
> >
> > Signed-off-by: Yosry Ahmed <yosryahmed@...gle.com>
>
> LGTM with one comment below:
>
> Reviewed-by: Chengming Zhou <chengming.zhou@...ux.dev>
>
> > ---
> > mm/zswap.c | 45 ++++++++++++++++++++++++---------------------
> > 1 file changed, 24 insertions(+), 21 deletions(-)
> >
> > diff --git a/mm/zswap.c b/mm/zswap.c
> > index 6b890c8590ef7..498a6c5839bef 100644
> > --- a/mm/zswap.c
> > +++ b/mm/zswap.c
> > @@ -1385,26 +1385,36 @@ static void shrink_worker(struct work_struct *w)
> > } while (zswap_total_pages() > thr);
> > }
> >
> > -static int zswap_is_page_same_filled(void *ptr, unsigned long *value)
> > +static bool zswap_is_folio_same_filled(struct folio *folio, unsigned long *value)
> > {
> > unsigned long *page;
> > unsigned long val;
> > unsigned int pos, last_pos = PAGE_SIZE / sizeof(*page) - 1;
> > + bool ret;
> >
> > - page = (unsigned long *)ptr;
> > + if (!zswap_same_filled_pages_enabled)
> > + return false;
> > +
> > + page = kmap_local_folio(folio, 0);
> > val = page[0];
> >
> > - if (val != page[last_pos])
> > - return 0;
> > + if (val != page[last_pos]) {
> > + ret = false;
> > + goto out;
> > + }
> >
> > for (pos = 1; pos < last_pos; pos++) {
> > - if (val != page[pos])
> > - return 0;
> > + if (val != page[pos]) {
> > + ret = false;
>
> nit: ret can be initialized to false, so
>
> > + goto out;
> > + }
> > }
> >
> > *value = val;
> > -
> > - return 1;
> > + ret = true;
>
> only need to set to true here.
I didn't bother improving the code here because patch 6 will replace
it anyway, but I will do that in the next version anyway, might as
well.
Thanks!
Powered by blists - more mailing lists