[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240331021926.2732572-1-xiongwei.song@windriver.com>
Date: Sun, 31 Mar 2024 10:19:22 +0800
From: <xiongwei.song@...driver.com>
To: <vbabka@...e.cz>, <rientjes@...gle.com>, <cl@...ux.com>,
<penberg@...nel.org>, <iamjoonsoo.kim@....com>,
<akpm@...ux-foundation.org>, <roman.gushchin@...ux.dev>,
<42.hyeyoo@...il.com>
CC: <linux-mm@...ck.org>, <linux-kernel@...r.kernel.org>,
<chengming.zhou@...ux.dev>
Subject: [PATCH 0/4] SLUB: improve filling cpu partial a bit in get_partial_node()
From: Xiongwei Song <xiongwei.song@...driver.com>
This series is to remove the unnecessary check for filling cpu partial
and improve the readability.
Introduce slub_get_cpu_partial() and dummy function to prevent compiler
warning with CONFIG_SLUB_CPU_PARTIAL disabled. This is done in patch 2.
Use the helper in patch 3 and 4.
No functionality changed.
Actually, the series is the improvement of patch below:
https://lore.kernel.org/lkml/934f65c6-4d97-6c4d-b123-4937ede24a99@google.com/T/
Regards,
Xiongwei
Xiongwei Song (4):
mm/slub: remove the check of !kmem_cache_has_cpu_partial()
mm/slub: add slub_get_cpu_partial() helper
mm/slub: simpilify get_partial_node()
mm/slub: don't read slab->cpu_partial_slabs directly
mm/slub.c | 35 +++++++++++++++++++++++------------
1 file changed, 23 insertions(+), 12 deletions(-)
--
2.27.0
Powered by blists - more mailing lists