[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <c0d1cf2420e103a36fd309ee1fcbbd4106ecdc48.camel@microchip.com>
Date: Tue, 2 Apr 2024 15:37:42 +0000
From: <Arun.Ramadoss@...rochip.com>
To: <andrew@...n.ch>, <olteanv@...il.com>, <davem@...emloft.net>,
<Woojung.Huh@...rochip.com>, <pabeni@...hat.com>, <o.rempel@...gutronix.de>,
<edumazet@...gle.com>, <f.fainelli@...il.com>, <kuba@...nel.org>
CC: <kernel@...gutronix.de>, <san@...v.dk>, <linux-kernel@...r.kernel.org>,
<netdev@...r.kernel.org>, <UNGLinuxDriver@...rochip.com>
Subject: Re: [PATCH net-next v1 3/8] net: dsa: microchip: ksz8: Refactor
ksz8_fdb_dump()
Hi Oleksij,
On Tue, 2024-04-02 at 15:13 +0200, Oleksij Rempel wrote:
> EXTERNAL EMAIL: Do not click links or open attachments unless you
> know the content is safe
>
> Refactor ksz8_fdb_dump() to address potential issues:
> - Limit the number of iterations to avoid endless loops.
> - Handle error codes returned by ksz8_r_dyn_mac_table(), with
> an exception for -ENXIO when no more dynamic entries are detected.
>
> Signed-off-by: Oleksij Rempel <o.rempel@...gutronix.de>
> ---
> drivers/net/dsa/microchip/ksz8795.c | 38 ++++++++++++++---------
> --
> drivers/net/dsa/microchip/ksz8795_reg.h | 1 +
> 2 files changed, 23 insertions(+), 16 deletions(-)
>
> diff --git a/drivers/net/dsa/microchip/ksz8795.c
> b/drivers/net/dsa/microchip/ksz8795.c
> index e407111db6637..b70aa2c0a85ec 100644
> --- a/drivers/net/dsa/microchip/ksz8795.c
> +++ b/drivers/net/dsa/microchip/ksz8795.c
> @@ -1191,27 +1191,33 @@ void ksz8_flush_dyn_mac_table(struct
> ksz_device *dev, int port)
> int ksz8_fdb_dump(struct ksz_device *dev, int port,
> dsa_fdb_dump_cb_t *cb, void *data)
> {
> - int ret = 0;
> - u16 i = 0;
> u16 entries = 0;
> - u8 fid;
> - u8 src_port;
> - u8 mac[ETH_ALEN];
> + int ret, i;
> +
> + for (i = 0; i < KSZ8_DYN_MAC_ENTRIES; i++) {
> + u8 mac[ETH_ALEN];
> + u8 src_port;
> + u8 fid;
IMO:Since there is no code other than for loop in this function,
variable declaraion can be as before.
>
> - do {
> ret = ksz8_r_dyn_mac_table(dev, i, mac, &fid,
> &src_port,
> &entries);
> - if (!ret && port == src_port) {
> - ret = cb(mac, fid, false, data);
> - if (ret)
> - break;
> - }
> - i++;
> - } while (i < entries);
> - if (i >= entries)
> - ret = 0;
> + if (ret == -ENXIO)
> + return 0;
> + if (ret)
> + return ret;
>
> - return ret;
> + if (i >= entries)
> + return 0;
> +
> + if (port != src_port)
> + continue;
IMO: since already many returns in function, if above statement
replaced as below will increase readability.
if (port == src_port) {
ret = cb(mac, fid, false, data);
if (ret)
return ret;
}
> +
> + ret = cb(mac, fid, false, data);
> + if (ret)
> + return ret;
> + }
> +
> + return 0;
> }
>
> static int ksz8_add_sta_mac(struct ksz_device *dev, int port,
> diff --git a/drivers/net/dsa/microchip/ksz8795_reg.h
> b/drivers/net/dsa/microchip/ksz8795_reg.h
> index 7c9341ef73b03..0d13a6e29b0e6 100644
> --- a/drivers/net/dsa/microchip/ksz8795_reg.h
> +++ b/drivers/net/dsa/microchip/ksz8795_reg.h
> @@ -794,5 +794,6 @@
> #define TAIL_TAG_LOOKUP BIT(7)
>
> #define FID_ENTRIES 128
> +#define KSZ8_DYN_MAC_ENTRIES 1024
>
> #endif
> --
> 2.39.2
>
Powered by blists - more mailing lists