[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <cover.1712410202.git.lukas@wunner.de>
Date: Sat, 6 Apr 2024 15:52:00 +0200
From: Lukas Wunner <lukas@...ner.de>
To: Greg Kroah-Hartman <gregkh@...uxfoundation.org>, "Rafael J. Wysocki" <rafael@...nel.org>, linux-kernel@...r.kernel.org
Cc: Michael Ellerman <mpe@...erman.id.au>, linuxppc-dev@...ts.ozlabs.org, linux-acpi@...r.kernel.org, Jean Delvare <jdelvare@...e.com>, Ard Biesheuvel <ardb@...nel.org>, linux-efi@...r.kernel.org, Zhenyu Wang <zhenyuw@...ux.intel.com>, Zhi Wang <zhi.wang.linux@...il.com>, intel-gvt-dev@...ts.freedesktop.org, Daniel Lezcano <daniel.lezcano@...aro.org>, linux-pm@...r.kernel.org, Luis Chamberlain <mcgrof@...nel.org>, linux-modules@...r.kernel.org
Subject: [PATCH 0/2] Deduplicate bin_attribute simple read() callbacks
For my upcoming PCI device authentication v2 patches, I have the need
to expose a simple buffer in virtual memory as a bin_attribute.
It turns out we've duplicated the ->read() callback for such simple
buffers a fair number of times across the tree.
So instead of reinventing the wheel, I decided to introduce a common
helper and eliminate all duplications I could find.
I'm open to a bikeshedding discussion on the sysfs_bin_attr_simple_read()
name. ;)
Lukas Wunner (2):
sysfs: Add sysfs_bin_attr_simple_read() helper
treewide: Use sysfs_bin_attr_simple_read() helper
arch/powerpc/platforms/powernv/opal.c | 10 +-------
drivers/acpi/bgrt.c | 9 +-------
drivers/firmware/dmi_scan.c | 12 ++--------
drivers/firmware/efi/rci2-table.c | 10 +-------
drivers/gpu/drm/i915/gvt/firmware.c | 26 +++++----------------
.../intel/int340x_thermal/int3400_thermal.c | 9 +-------
fs/sysfs/file.c | 27 ++++++++++++++++++++++
include/linux/sysfs.h | 15 ++++++++++++
init/initramfs.c | 10 +-------
kernel/module/sysfs.c | 13 +----------
10 files changed, 56 insertions(+), 85 deletions(-)
--
2.43.0
Powered by blists - more mailing lists