[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <bvcyipeq22p3gtozzpb3jkmp2tcjgil2hru3ecussflroxiz2r@4nr3f7elpmvs>
Date: Mon, 8 Apr 2024 21:38:26 +0000
From: Justin Stitt <justinstitt@...gle.com>
To: Erick Archer <erick.archer@...look.com>
Cc: Long Li <longli@...rosoft.com>, Ajay Sharma <sharmaajay@...rosoft.com>,
"K. Y. Srinivasan" <kys@...rosoft.com>, Haiyang Zhang <haiyangz@...rosoft.com>,
Wei Liu <wei.liu@...nel.org>, Dexuan Cui <decui@...rosoft.com>,
"David S. Miller" <davem@...emloft.net>, Eric Dumazet <edumazet@...gle.com>,
Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>,
Kees Cook <keescook@...omium.org>, "Gustavo A. R. Silva" <gustavoars@...nel.org>,
Nathan Chancellor <nathan@...nel.org>, Nick Desaulniers <ndesaulniers@...gle.com>,
Bill Wendling <morbo@...gle.com>, Jason Gunthorpe <jgg@...pe.ca>,
Leon Romanovsky <leon@...nel.org>, Shradha Gupta <shradhagupta@...ux.microsoft.com>,
Konstantin Taranov <kotaranov@...rosoft.com>, linux-rdma@...r.kernel.org, linux-hyperv@...r.kernel.org,
netdev@...r.kernel.org, linux-kernel@...r.kernel.org, linux-hardening@...r.kernel.org,
llvm@...ts.linux.dev
Subject: Re: [PATCH v3 2/3] RDMA/mana_ib: Prefer struct_size over open coded
arithmetic
Hi,
On Sat, Apr 06, 2024 at 04:23:36PM +0200, Erick Archer wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1][2].
>
> As the "req" variable is a pointer to "struct mana_cfg_rx_steer_req_v2"
> and this structure ends in a flexible array:
>
> struct mana_cfg_rx_steer_req_v2 {
> [...]
> mana_handle_t indir_tab[] __counted_by(num_indir_entries);
> };
>
> the preferred way in the kernel is to use the struct_size() helper to
> do the arithmetic instead of the calculation "size + size * count" in
> the kzalloc() function.
>
> Moreover, use the "offsetof" helper to get the indirect table offset
> instead of the "sizeof" operator and avoid the open-coded arithmetic in
> pointers using the new flex member. This new structure member also allow
> us to remove the "req_indir_tab" variable since it is no longer needed.
>
> This way, the code is more readable and safer.
>
> This code was detected with the help of Coccinelle, and audited and
> modified manually.
>
> Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/160 [2]
> Signed-off-by: Erick Archer <erick.archer@...look.com>
Reviewed-by: Justin Stitt <justinstitt@...gle.com>
> ---
> drivers/infiniband/hw/mana/qp.c | 12 +++++-------
> 1 file changed, 5 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/infiniband/hw/mana/qp.c b/drivers/infiniband/hw/mana/qp.c
> index ef0a6dc664d0..4cd8f8afe80d 100644
> --- a/drivers/infiniband/hw/mana/qp.c
> +++ b/drivers/infiniband/hw/mana/qp.c
> @@ -15,15 +15,13 @@ static int mana_ib_cfg_vport_steering(struct mana_ib_dev *dev,
> struct mana_port_context *mpc = netdev_priv(ndev);
> struct mana_cfg_rx_steer_req_v2 *req;
> struct mana_cfg_rx_steer_resp resp = {};
> - mana_handle_t *req_indir_tab;
> struct gdma_context *gc;
> u32 req_buf_size;
> int i, err;
>
> gc = mdev_to_gc(dev);
>
> - req_buf_size =
> - sizeof(*req) + sizeof(mana_handle_t) * MANA_INDIRECT_TABLE_SIZE;
> + req_buf_size = struct_size(req, indir_tab, MANA_INDIRECT_TABLE_SIZE);
> req = kzalloc(req_buf_size, GFP_KERNEL);
> if (!req)
> return -ENOMEM;
> @@ -44,20 +42,20 @@ static int mana_ib_cfg_vport_steering(struct mana_ib_dev *dev,
> req->rss_enable = true;
>
> req->num_indir_entries = MANA_INDIRECT_TABLE_SIZE;
> - req->indir_tab_offset = sizeof(*req);
> + req->indir_tab_offset = offsetof(struct mana_cfg_rx_steer_req_v2,
> + indir_tab);
> req->update_indir_tab = true;
> req->cqe_coalescing_enable = 1;
>
> - req_indir_tab = (mana_handle_t *)(req + 1);
> /* The ind table passed to the hardware must have
> * MANA_INDIRECT_TABLE_SIZE entries. Adjust the verb
> * ind_table to MANA_INDIRECT_TABLE_SIZE if required
> */
> ibdev_dbg(&dev->ib_dev, "ind table size %u\n", 1 << log_ind_tbl_size);
> for (i = 0; i < MANA_INDIRECT_TABLE_SIZE; i++) {
> - req_indir_tab[i] = ind_table[i % (1 << log_ind_tbl_size)];
> + req->indir_tab[i] = ind_table[i % (1 << log_ind_tbl_size)];
> ibdev_dbg(&dev->ib_dev, "index %u handle 0x%llx\n", i,
> - req_indir_tab[i]);
> + req->indir_tab[i]);
> }
>
> req->update_hashkey = true;
> --
> 2.25.1
>
Thanks
Justin
Powered by blists - more mailing lists