[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Zh1y25IizELqexR2@fedora>
Date: Mon, 15 Apr 2024 11:32:59 -0700
From: Vishal Moola <vishal.moola@...il.com>
To: Sidhartha Kumar <sidhartha.kumar@...cle.com>
Cc: linux-kernel@...r.kernel.org, linux-mm@...ck.org,
akpm@...ux-foundation.org, willy@...radead.org,
linmiaohe@...wei.com, jane.chu@...cle.com, muchun.song@...ux.dev,
nao.horiguchi@...il.com, osalvador@...e.de
Subject: Re: [PATCH v2 2/2] mm/hugetlb: rename dissolve_free_huge_pages() to
dissolve_free_hugetlb_folios()
On Fri, Apr 12, 2024 at 11:21:39AM -0700, Sidhartha Kumar wrote:
> dissolve_free_huge_pages() only uses folios internally, rename it to
> dissolve_free_hugetlb_folios() and change the comments which reference it.
>
> Signed-off-by: Sidhartha Kumar <sidhartha.kumar@...cle.com>
> ---
> include/linux/hugetlb.h | 4 ++--
> mm/hugetlb.c | 2 +-
> mm/memory_hotplug.c | 4 ++--
> 3 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/include/linux/hugetlb.h b/include/linux/hugetlb.h
> index f4191b10345d6..9ad7b97069cda 100644
> --- a/include/linux/hugetlb.h
> +++ b/include/linux/hugetlb.h
> @@ -862,7 +862,7 @@ static inline int hstate_index(struct hstate *h)
> }
>
> extern int dissolve_free_hugetlb_folio(struct folio *folio);
> -extern int dissolve_free_huge_pages(unsigned long start_pfn,
> +extern int dissolve_free_hugetlb_folios(unsigned long start_pfn,
> unsigned long end_pfn);
Same comment as the prior patch.
Reviewed-by: Vishal Moola (Oracle) <vishal.moola@...il.com>
Powered by blists - more mailing lists