[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <714199e5-edf2-dcbb-216b-563431d70488@bootlin.com>
Date: Tue, 16 Apr 2024 09:56:32 +0200 (CEST)
From: Romain Gantois <romain.gantois@...tlin.com>
To: Serge Semin <fancer.lancer@...il.com>
cc: Alexandre Torgue <alexandre.torgue@...s.st.com>,
Jose Abreu <joabreu@...opsys.com>, "David S. Miller" <davem@...emloft.net>,
Eric Dumazet <edumazet@...gle.com>, Jakub Kicinski <kuba@...nel.org>,
Paolo Abeni <pabeni@...hat.com>, Russell King <linux@...linux.org.uk>,
Yanteng Si <siyanteng@...ngson.cn>,
Maxime Coquelin <mcoquelin.stm32@...il.com>,
Simon Horman <horms@...nel.org>, Huacai Chen <chenhuacai@...nel.org>,
Chen-Yu Tsai <wens@...e.org>, Jernej Skrabec <jernej.skrabec@...il.com>,
Samuel Holland <samuel@...lland.org>, netdev@...r.kernel.org,
linux-stm32@...md-mailman.stormreply.com,
linux-arm-kernel@...ts.infradead.org, linux-sunxi@...ts.linux.dev,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH net-next 4/4] net: stmmac: Move MAC caps init to phylink
MAC caps getter
Hi Serge,
On Fri, 12 Apr 2024, Serge Semin wrote:
> +static unsigned long stmmac_mac_get_caps(struct phylink_config *config,
> + phy_interface_t interface)
> +{
> + struct stmmac_priv *priv = netdev_priv(to_net_dev(config->dev));
> +
> + /* Get the MAC-specific capabilities */
> + stmmac_mac_phylink_get_caps(priv);
This is a bit of a nitpick, but the terminology is quite confusing between
stmmac_mac_phylink_get_caps() and stmmac_mac_get_caps(). Ideally, we could just
get rid of the whole stmmac_do_void_callback() complexity and just call
phylink_get_caps() directly. In the meantime, maybe renaming this to
stmmac_mac_core_get_caps() would be acceptable?
Please let me know what you think.
Thanks,
--
Romain Gantois, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com
Powered by blists - more mailing lists