[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240417170054.140587-1-alisa.roman@analog.com>
Date: Wed, 17 Apr 2024 20:00:49 +0300
From: Alisa-Dariana Roman <alisadariana@...il.com>
To: michael.hennerich@...log.com,
linux-iio@...r.kernel.org,
devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org
Cc: alexandru.tachici@...log.com,
lars@...afoo.de,
Michael.Hennerich@...log.com,
jic23@...nel.org,
robh@...nel.org,
krzysztof.kozlowski+dt@...aro.org,
conor+dt@...nel.org,
lgirdwood@...il.com,
broonie@...nel.org,
andy@...nel.org,
nuno.sa@...log.com,
marcelo.schmitt@...log.com,
bigunclemax@...il.com,
dlechner@...libre.com,
okan.sahin@...log.com,
fr0st61te@...il.com,
alisa.roman@...log.com,
marcus.folkesson@...il.com,
schnelle@...ux.ibm.com,
liambeguin@...il.com
Subject: [PATCH v6 0/5] iio: adc: ad7192: Add AD7194 support
Dear maintainers,
Thank you all for the feedback!
I am submitting the upgraded series of patches for the ad7192 driver.
Please consider applying in order.
Thank you!
v5 -> v6
- protect ad7192_update_filter_freq_avail with lock
- better bindings description for AINCOM
- the pseudo-differential channels are no longer configured as differential
when aincom supply is not present in devicetree, in this case the offset for
the channels is set to 0
- because of the above change, there is no longer a need for multiple channel
options
- correct channels regex in bindings
- no need to move chip_info anymore
- change names to ad7194_parse_channel/s
- add else statement to highlight parse_channels effect
v4 -> v5
- add aincom supply as discussed previously
https://lore.kernel.org/all/CAMknhBF5mAsN1c-194Qwa5oKmqKzef2khXnqA1cSdKpWHKWp0w@mail.gmail.com/#t
- ad7194 differential channels are now dynamically configured in the
devicetree
v3 -> v4
- drop device properties patch, changes already applied to tree
- change bindings and driver such that for AD7194 there are 16
differential channels, by default set to AINx - AINCOM, which can be
configured in devicetree however the user likes
- corrected mistake regarding positive and negative channel macros:
subtract 1 from the number corresponding to AIN input
v2 -> v3
- add precursor patch to simply functions to only pass
ad7192_state
- add patch to replace custom attribute
- bindings patch: correct use of allOf and some minor changes to
the ad7194 example
- add ad7194 patch:
- use "ad7192 and similar"
- ad7194 no longer needs attribute group
- use callback function in chip_info to parse channels
- move struct ad7192_chip_info
- change position of parse functions
- drop clock bindings patch
v1 -> v2
- new commit with missing documentation for properties
- add constraint for channels in binding
- correct pattern for channels
- correct commit message by adding "()" to functions
- use in_range
- use preferred structure in Kconfig
Kind regards,
Alisa-Dariana Roman (5):
iio: adc: ad7192: Use standard attribute
dt-bindings: iio: adc: ad7192: Add aincom supply
iio: adc: ad7192: Add aincom supply
dt-bindings: iio: adc: ad7192: Add AD7194 support
iio: adc: ad7192: Add AD7194 support
.../bindings/iio/adc/adi,ad7192.yaml | 83 +++++++
drivers/iio/adc/Kconfig | 11 +-
drivers/iio/adc/ad7192.c | 226 ++++++++++++++----
3 files changed, 274 insertions(+), 46 deletions(-)
--
2.34.1
Powered by blists - more mailing lists