[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <2f505724-4b2c-48ee-90af-52f5d5fa95d7@kernel.org>
Date: Mon, 22 Apr 2024 08:34:45 +0200
From: Jiri Slaby <jirislaby@...nel.org>
To: Parker Newman <parker@...est.io>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
linux-kernel@...r.kernel.org, linux-serial@...r.kernel.org
Cc: Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>,
Parker Newman <pnewman@...necttech.com>
Subject: Re: [PATCH v2 4/4] serial: exar: remove ternaries from
cti_get_port_type_xr17c15x_xr17v25x()
On 19. 04. 24, 16:17, Parker Newman wrote:
> From: Parker Newman <pnewman@...necttech.com>
>
> Remove ternary operators from cti_get_port_type_xr17c15x_xr17v25x() for
> better readability.
>
> Signed-off-by: Parker Newman <pnewman@...necttech.com>
Much better.
Reviewed-by: Jiri Slaby <jirislaby@...nel.org>
> --- a/drivers/tty/serial/8250/8250_exar.c
> +++ b/drivers/tty/serial/8250/8250_exar.c
> @@ -726,7 +726,7 @@ static enum cti_port_type cti_get_port_type_xr17c15x_xr17v25x(struct exar8250 *p
> struct pci_dev *pcidev,
> unsigned int port_num)
> {
> - enum cti_port_type port_type;
> + enum cti_port_type port_type = CTI_PORT_TYPE_RS232;
>
> switch (pcidev->subsystem_device) {
> // RS232 only cards
Unrelated to this one, but // comments are discouraged in the kernel, IMO?
thanks,
--
js
suse labs
Powered by blists - more mailing lists