lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Mon, 29 Apr 2024 21:00:36 +0200
From: Vasileios Amoiridis <vassilisamir@...il.com>
To: jic23@...nel.org
Cc: lars@...afoo.de,
	andriy.shevchenko@...ux.intel.com,
	ang.iglesiasg@...il.com,
	mazziesaccount@...il.com,
	ak@...klinger.de,
	petre.rodan@...dimension.ro,
	phil@...pberrypi.com,
	579lpy@...il.com,
	linus.walleij@...aro.org,
	semen.protsenko@...aro.org,
	linux-iio@...r.kernel.org,
	linux-kernel@...r.kernel.org,
	Vasileios Amoiridis <vassilisamir@...il.com>
Subject: [PATCH v5 00/10] iio: pressure: bmp280: Driver cleanup and add triggered buffer support

Based on next-20240429.

Changes in v5:

Patch [1-5/10]: *new*:
	- Splitted various driver cleanups that were gathered in Patch [1/6] of
	  previous version.

Patch [7/10]:
	- Patch [3/6] of v4
	- Removed extra dead code due to guard(mutex)

Patch [10/10]:
	- Patch [6/6] of v4
	- Fixed comment alignment
	- Fixed struct alignment in order to have timestamp properly aligned.


[v4]: https://lore.kernel.org/linux-iio/20240407172920.264282-1-vassilisamir@gmail.com/
[v3]: https://lore.kernel.org/linux-iio/20240319002925.2121016-1-vassilisamir@gmail.com/
[v2]: https://lore.kernel.org/linux-iio/20240313174007.1934983-1-vassilisamir@gmail.com/
[v1]: https://lore.kernel.org/linux-iio/20240303165300.468011-1-vassilisamir@gmail.com/

Vasileios Amoiridis (10):
  iio: pressure: bmp280: Improve indentation and line wrapping
  iio: pressure: bmp280: Use BME prefix for BME280 specifics
  iio: pressure: bmp280: Add identifier names in function definitions
  iio: pressure: bmp280: Add more intuitive name for bmp180_measure()
  iio: pressure: bmp280: Make return values consistent
  iio: pressure: bmp280: Refactorize reading functions
  iio: pressure: bmp280: Introduce new cleanup routines
  iio: pressure: bmp280: Generalize read_{temp,press,humid}() functions
  iio: pressure: bmp280: Add SCALE, RAW values in channels and
    refactorize them
  iio: pressure: bmp280: Add triggered buffer support

 drivers/iio/pressure/Kconfig         |    2 +
 drivers/iio/pressure/bmp280-core.c   | 1336 ++++++++++++++++++--------
 drivers/iio/pressure/bmp280-regmap.c |    8 +-
 drivers/iio/pressure/bmp280-spi.c    |   12 +-
 drivers/iio/pressure/bmp280.h        |   87 +-
 5 files changed, 978 insertions(+), 467 deletions(-)


base-commit: b0a2c79c6f3590b74742cbbc76687014d47972d8
-- 
2.25.1


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ