[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <penqmxyjpw5jukmqbmsrjbvqxhugrhbk6gruie4pjdoacah5zr@atcvnu6ogksv>
Date: Mon, 29 Apr 2024 23:29:32 -0400
From: Kent Overstreet <kent.overstreet@...ux.dev>
To: Youling Tang <youling.tang@...ux.dev>
Cc: linux-bcachefs@...r.kernel.org, linux-kernel@...r.kernel.org,
Youling Tang <tangyouling@...inos.cn>
Subject: Re: [PATCH] bcachefs: Correct the FS_IOC_GETFLAGS to
FS_IOC32_GETFLAGS in bch2_compat_fs_ioctl()
On Tue, Apr 30, 2024 at 11:27:44AM +0800, Youling Tang wrote:
> From: Youling Tang <tangyouling@...inos.cn>
>
> It should be FS_IOC32_GETFLAGS instead of FS_IOC_GETFLAGS in
> compat ioctl.
Do we by chance have a test for this?
>
> Signed-off-by: Youling Tang <tangyouling@...inos.cn>
> ---
> fs/bcachefs/fs-ioctl.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/fs/bcachefs/fs-ioctl.c b/fs/bcachefs/fs-ioctl.c
> index 3dc8630ff9fe..205a323ffc6d 100644
> --- a/fs/bcachefs/fs-ioctl.c
> +++ b/fs/bcachefs/fs-ioctl.c
> @@ -548,7 +548,7 @@ long bch2_compat_fs_ioctl(struct file *file, unsigned cmd, unsigned long arg)
> {
> /* These are just misnamed, they actually get/put from/to user an int */
> switch (cmd) {
> - case FS_IOC_GETFLAGS:
> + case FS_IOC32_GETFLAGS:
> cmd = FS_IOC_GETFLAGS;
> break;
> case FS_IOC32_SETFLAGS:
> --
> 2.34.1
>
Powered by blists - more mailing lists