[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ba140a7b-0627-4d73-8267-8721f6ce1c63@gmail.com>
Date: Tue, 30 Apr 2024 15:08:51 -0700
From: Florian Fainelli <f.fainelli@...il.com>
To: Daniel Golle <daniel@...rotopia.org>, Arınç ÜNAL
<arinc.unal@...nc9.com>, Felix Fietkau <nbd@....name>,
Rob Herring <robh@...nel.org>, Krzysztof Kozlowski <krzk+dt@...nel.org>,
Conor Dooley <conor+dt@...nel.org>, Simon Horman <horms@...nel.org>,
DENG Qingfang <dqfext@...il.com>, Sean Wang <sean.wang@...iatek.com>,
Andrew Lunn <andrew@...n.ch>, Vladimir Oltean <olteanv@...il.com>,
"David S. Miller" <davem@...emloft.net>, Eric Dumazet <edumazet@...gle.com>,
Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>,
Matthias Brugger <matthias.bgg@...il.com>,
AngeloGioacchino Del Regno <angelogioacchino.delregno@...labora.com>,
Landen Chao <Landen.Chao@...iatek.com>, devicetree@...r.kernel.org,
netdev@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-arm-kernel@...ts.infradead.org, linux-mediatek@...ts.infradead.org
Subject: Re: [PATCH net v2] net: dsa: mt7530: fix impossible MDIO address and
issue warning
On 4/30/24 15:01, Daniel Golle wrote:
> The MDIO address of the MT7530 and MT7531 switch ICs can be configured
> using bootstrap pins. However, there are only 4 possible options for the
> switch itself: 7, 15, 23 and 31. As in MediaTek's SDK the address of the
> switch is wrongly stated in the device tree as 0 (while in reality it is
> 31), warn the user about such broken device tree and make a good guess
> what was actually intended.
>
> This is imporant also to not break compatibility with older device trees
> as with commit 868ff5f4944a ("net: dsa: mt7530-mdio: read PHY address of
> switch from device tree") the address in device tree will be taken into
> account.
>
> Fixes: b8f126a8d543 ("net-next: dsa: add dsa support for Mediatek MT7530 switch")
> Signed-off-by: Daniel Golle <daniel@...rotopia.org>
> ---
> Changes since v1:
> - use FW_WARN as suggested.
> - fix build on net tree which doesn't have 'mdiodev' as member of the
> priv struct. Imho including this patch as fix makes sense to warn
> users about broken firmware, even if the change introducing the
> actual breakage is only present in net-next for now.
>
> drivers/net/dsa/mt7530-mdio.c | 13 +++++++++++++
> 1 file changed, 13 insertions(+)
>
> diff --git a/drivers/net/dsa/mt7530-mdio.c b/drivers/net/dsa/mt7530-mdio.c
> index fa3ee85a99c1..3c21c8d074c7 100644
> --- a/drivers/net/dsa/mt7530-mdio.c
> +++ b/drivers/net/dsa/mt7530-mdio.c
> @@ -193,6 +193,19 @@ mt7530_probe(struct mdio_device *mdiodev)
> return PTR_ERR(priv->io_pwr);
> }
>
> + /* Only MDIO bus address 7, 15, 23 and 31 are valid options */
> + if (~(mdiodev->addr & 0x7) & 0x7) {
> + /* If the address in DT must be wrong, make a good guess about
> + * the most likely intention, and issue a warning.
> + */
> + int correct_addr = ((((mdiodev->addr - 7) & ~0x7) % 0x20) + 7) & 0x1f;
0x20 -> PHY_MAX_ADDR
0x1F -> PHY_MAX_ADDR - 1
> +
> + dev_warn(&mdiodev->dev, FW_WARN
> + "impossible switch MDIO address in device tree: %d, assuming %d\n",
> + mdiodev->addr, correct_addr);
> + mdiodev->addr = correct_addr;
Sorry for not jumping on this earlier on, there is a mixture of
hexadecimal and decimal numbers being used which IMHO just makes this
more difficult to read than needed. It seems like the requirement is for
the switch's MDIO device address to have the lower 3 bits set, so can we
give it a name like MT7530_MDIO_ADDR_VALID_MASK?
--
Florian
Powered by blists - more mailing lists