[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20240507021714.29689-1-zhangwarden@gmail.com>
Date: Tue, 7 May 2024 10:17:13 +0800
From: zhangwarden@...il.com
To: jpoimboe@...nel.org,
mbenes@...e.cz,
jikos@...nel.org,
pmladek@...e.com,
joe.lawrence@...hat.com
Cc: live-patching@...r.kernel.org,
linux-kernel@...r.kernel.org,
Wardenjohn <zhangwarden@...il.com>
Subject: [PATCH 0/1] *** Replace KLP_* to KLP_TRANSITION_* ***
From: Wardenjohn <zhangwarden@...il.com>
As the previous described, renaming variables is not a good idead
becase it will break userspace. This patch rename macros of KLP_*
to KLP_TRANSITION_* to fix the confusing description of the klp
transition state. With this marcos renamed, comments are not
necessary at this point.
Wardenjohn (1):
livepatch: Rename KLP_* to KLP_TRANSITION_*
include/linux/livepatch.h | 6 ++--
init/init_task.c | 2 +-
kernel/livepatch/core.c | 5 ++--
kernel/livepatch/patch.c | 4 +--
kernel/livepatch/transition.c | 54 +++++++++++++++++------------------
5 files changed, 36 insertions(+), 35 deletions(-)
--
2.37.3
Powered by blists - more mailing lists