[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAM9d7chQ9UW3+axnCSCYeOi3mRSwJbSmUS0YzTRa8tuXr1TbBA@mail.gmail.com>
Date: Tue, 7 May 2024 21:06:39 -0700
From: Namhyung Kim <namhyung@...nel.org>
To: James Clark <james.clark@....com>
Cc: linux-perf-users@...r.kernel.org, atrajeev@...ux.vnet.ibm.com,
irogers@...gle.com, Peter Zijlstra <peterz@...radead.org>, Ingo Molnar <mingo@...hat.com>,
Arnaldo Carvalho de Melo <acme@...nel.org>, Mark Rutland <mark.rutland@....com>,
Alexander Shishkin <alexander.shishkin@...ux.intel.com>, Jiri Olsa <jolsa@...nel.org>,
Adrian Hunter <adrian.hunter@...el.com>, "Liang, Kan" <kan.liang@...ux.intel.com>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/4] perf maps: Re-use __maps__free_maps_by_name()
On Tue, May 7, 2024 at 7:13 AM James Clark <james.clark@....com> wrote:
>
> maps__merge_in() hard codes the steps to free the maps_by_name list. It
> seems to not map__put() each element before freeing, and it sets
> maps_by_name_sorted to true after freeing, which may be harmless but
> is inconsistent with maps__init() and other functions.
>
> maps__maps_by_name_addr() is also quite hard to read because we already
> have maps__maps_by_name() and maps__maps_by_address(), but the function
> is only used in that place so delete it.
Agreed, I feel like we need some more cleanup here.
Thanks,
Namhyung
>
> Signed-off-by: James Clark <james.clark@....com>
> ---
> tools/perf/util/maps.c | 14 +++++++-------
> 1 file changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/tools/perf/util/maps.c b/tools/perf/util/maps.c
> index 61eb742d91e3..16b39db594f4 100644
> --- a/tools/perf/util/maps.c
> +++ b/tools/perf/util/maps.c
> @@ -124,11 +124,6 @@ static void maps__set_maps_by_address(struct maps *maps, struct map **new)
>
> }
>
> -static struct map ***maps__maps_by_name_addr(struct maps *maps)
> -{
> - return &RC_CHK_ACCESS(maps)->maps_by_name;
> -}
> -
> static void maps__set_nr_maps_allocated(struct maps *maps, unsigned int nr_maps_allocated)
> {
> RC_CHK_ACCESS(maps)->nr_maps_allocated = nr_maps_allocated;
> @@ -284,6 +279,9 @@ void maps__put(struct maps *maps)
>
> static void __maps__free_maps_by_name(struct maps *maps)
> {
> + if (!maps__maps_by_name(maps))
> + return;
> +
> /*
> * Free everything to try to do it from the rbtree in the next search
> */
> @@ -291,6 +289,9 @@ static void __maps__free_maps_by_name(struct maps *maps)
> map__put(maps__maps_by_name(maps)[i]);
>
> zfree(&RC_CHK_ACCESS(maps)->maps_by_name);
> +
> + /* Consistent with maps__init(). When maps_by_name == NULL, maps_by_name_sorted == false */
> + maps__set_maps_by_name_sorted(maps, false);
> }
>
> static int map__start_cmp(const void *a, const void *b)
> @@ -1167,8 +1168,7 @@ int maps__merge_in(struct maps *kmaps, struct map *new_map)
> }
> maps__set_maps_by_address(kmaps, merged_maps_by_address);
> maps__set_maps_by_address_sorted(kmaps, true);
> - zfree(maps__maps_by_name_addr(kmaps));
> - maps__set_maps_by_name_sorted(kmaps, true);
> + __maps__free_maps_by_name(kmaps);
> maps__set_nr_maps_allocated(kmaps, merged_nr_maps_allocated);
>
> /* Copy entries before the new_map that can't overlap. */
> --
> 2.34.1
>
Powered by blists - more mailing lists