[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAHwB_NKtw0AyMgFb4rMFNgr4WF10o9_0pYvbKpnDM45aYma9zg@mail.gmail.com>
Date: Fri, 10 May 2024 09:16:03 +0800
From: cong yang <yangcong5@...qin.corp-partner.google.com>
To: Doug Anderson <dianders@...omium.org>
Cc: sam@...nborg.org, neil.armstrong@...aro.org, daniel@...ll.ch,
linus.walleij@...aro.org, krzysztof.kozlowski+dt@...aro.org,
robh+dt@...nel.org, conor+dt@...nel.org, airlied@...il.com,
dri-devel@...ts.freedesktop.org, devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org, xuxinxiong@...qin.corp-partner.google.com
Subject: Re: [PATCH v5 2/7] drm/panel: himax-hx83102: Break out as separate driver
Hi,
Doug Anderson <dianders@...omium.org> 于2024年5月10日周五 00:42写道:
>
> Hi,
>
> On Wed, May 8, 2024 at 6:53 PM Cong Yang
> <yangcong5@...qin.corp-partner.google.com> wrote:
> >
> > +static int hx83102_enable(struct drm_panel *panel)
> > +{
> > + struct hx83102 *ctx = panel_to_hx83102(panel);
> > + struct mipi_dsi_device *dsi = ctx->dsi;
> > + struct device *dev = &dsi->dev;
> > + int ret;
> > +
> > + ret = mipi_dsi_dcs_exit_sleep_mode(dsi);
> > + if (ret) {
> > + dev_err(dev, "Failed to exit sleep mode: %d\n", ret);
> > + return ret;
> > + }
> > +
> > + msleep(120);
> > +
> > + ret = mipi_dsi_dcs_set_display_on(dsi);
> > + if (ret) {
> > + dev_err(dev, "Failed to turn on the display: %d\n", ret);
> > + return ret;
> > + }
>
> FWIW, I think that the mipi_dsi_dcs_exit_sleep_mode(), msleep(120),
> and mipi_dsi_dcs_set_display_on() should also be in the prepare() to
> match how they were in the boe-tv101wum-nl6.c driver, right? Then the
> enable() would be left with just the simple "msleep(130)".
>
> I know it doesn't make much difference and it probably doesn't matter
> and maybe I'm just being a little nitpicky, but given that the
> prepare() and enable() functions are unique phases I'd rather be
> explicit if we've moving something from one phase to the other.
Yes, if it is consistent with the boe-tv101wum-nl6.c driver, then it
should be moved to prepare().
However, I was working from the driver readability,
enable() corresponds to 0x11 & 0x29.
disable() corresponds to 0x28 & 0x10.
.
Ok, I'll be happy to send V6 version to fix that, thanks!
>
>
> -Doug
Powered by blists - more mailing lists