[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240510190613.72838bf0@kernel.org>
Date: Fri, 10 May 2024 19:06:13 -0700
From: Jakub Kicinski <kuba@...nel.org>
To: Ryosuke Yasuoka <ryasuoka@...hat.com>
Cc: krzk@...nel.org, davem@...emloft.net, edumazet@...gle.com,
pabeni@...hat.com, horms@...nel.org, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org, syoshida@...hat.com,
syzbot+d7b4dc6cd50410152534@...kaller.appspotmail.com
Subject: Re: [PATCH net v4] nfc: nci: Fix uninit-value in nci_rx_work
On Thu, 9 May 2024 20:30:33 +0900 Ryosuke Yasuoka wrote:
> - if (!nci_plen(skb->data)) {
> + if (!skb->len) {
> kfree_skb(skb);
> - kcov_remote_stop();
> - break;
> + continue;
the change from break to continue looks unrelated
> }
> - nci_ntf_packet(ndev, skb);
> + if (nci_valid_size(skb, NCI_CTRL_HDR_SIZE))
> + if (nci_valid_size(skb, NCI_DATA_HDR_SIZE))
#define NCI_CTRL_HDR_SIZE 3
#define NCI_DATA_HDR_SIZE 3
you can add a BUILD_BUG_ON(NCI_CTRL_HDR_SIZE == NCI_DATA_HDR_SIZE)
and save all the code duplication.
Powered by blists - more mailing lists