[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240514104125.GD2787@kernel.org>
Date: Tue, 14 May 2024 11:41:25 +0100
From: Simon Horman <horms@...nel.org>
To: Bharat Bhushan <bbhushan2@...vell.com>
Cc: "netdev@...r.kernel.org" <netdev@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
Sunil Kovvuri Goutham <sgoutham@...vell.com>,
Geethasowjanya Akula <gakula@...vell.com>,
Subbaraya Sundeep Bhatta <sbhatta@...vell.com>,
Hariprasad Kelam <hkelam@...vell.com>,
"davem@...emloft.net" <davem@...emloft.net>,
"edumazet@...gle.com" <edumazet@...gle.com>,
"kuba@...nel.org" <kuba@...nel.org>,
"pabeni@...hat.com" <pabeni@...hat.com>,
Jerin Jacob <jerinj@...vell.com>,
Linu Cherian <lcherian@...vell.com>,
"richardcochran@...il.com" <richardcochran@...il.com>
Subject: Re: [EXTERNAL] Re: [net-next,v2 3/8] octeontx2-af: Disable
backpressure between CPT and NIX
On Tue, May 14, 2024 at 06:39:45AM +0000, Bharat Bhushan wrote:
> Please see inline
>
> > -----Original Message-----
> > From: Simon Horman <horms@...nel.org>
> > Sent: Monday, May 13, 2024 9:45 PM
> > To: Bharat Bhushan <bbhushan2@...vell.com>
> > Cc: netdev@...r.kernel.org; linux-kernel@...r.kernel.org; Sunil Kovvuri
> > Goutham <sgoutham@...vell.com>; Geethasowjanya Akula
> > <gakula@...vell.com>; Subbaraya Sundeep Bhatta <sbhatta@...vell.com>;
> > Hariprasad Kelam <hkelam@...vell.com>; davem@...emloft.net;
> > edumazet@...gle.com; kuba@...nel.org; pabeni@...hat.com; Jerin Jacob
> > <jerinj@...vell.com>; Linu Cherian <lcherian@...vell.com>;
> > richardcochran@...il.com
> > Subject: [EXTERNAL] Re: [net-next,v2 3/8] octeontx2-af: Disable backpressure
> > between CPT and NIX
> >
> >
> > ----------------------------------------------------------------------
> > On Mon, May 13, 2024 at 04:24:41PM +0530, Bharat Bhushan wrote:
> > > NIX can assert backpressure to CPT on the NIX<=>CPT link.
> > > Keep the backpressure disabled for now. NIX block anyways
> > > handles backpressure asserted by MAC due to PFC or flow
> > > control pkts.
> > >
> > > Signed-off-by: Bharat Bhushan <bbhushan2@...vell.com>
> >
> > ...
> >
> > > diff --git a/drivers/net/ethernet/marvell/octeontx2/af/rvu_nix.c
> > b/drivers/net/ethernet/marvell/octeontx2/af/rvu_nix.c
> >
> > ...
> >
> > > @@ -592,8 +596,16 @@ int rvu_mbox_handler_nix_bp_disable(struct rvu
> > *rvu,
> > > bp = &nix_hw->bp;
> > > chan_base = pfvf->rx_chan_base + req->chan_base;
> > > for (chan = chan_base; chan < (chan_base + req->chan_cnt); chan++) {
> > > - cfg = rvu_read64(rvu, blkaddr,
> > NIX_AF_RX_CHANX_CFG(chan));
> > > - rvu_write64(rvu, blkaddr, NIX_AF_RX_CHANX_CFG(chan),
> > > + /* CPT channel for a given link channel is always
> > > + * assumed to be BIT(11) set in link channel.
> > > + */
> > > + if (cpt_link)
> > > + chan_v = chan | BIT(11);
> > > + else
> > > + chan_v = chan;
> >
> > Hi Bharat,
> >
> > The chan_v logic above seems to appear twice in this patch.
> > I'd suggest adding a helper.
>
> Will fix in next version.
>
> >
> > > +
> > > + cfg = rvu_read64(rvu, blkaddr,
> > NIX_AF_RX_CHANX_CFG(chan_v));
> > > + rvu_write64(rvu, blkaddr, NIX_AF_RX_CHANX_CFG(chan_v),
> > > cfg & ~BIT_ULL(16));
> > >
> > > if (type == NIX_INTF_TYPE_LBK) {
> >
> > ...
> >
> > > diff --git a/drivers/net/ethernet/marvell/octeontx2/nic/otx2_common.c
> > b/drivers/net/ethernet/marvell/octeontx2/nic/otx2_common.c
> > > index 7ec99c8d610c..e9d2e039a322 100644
> > > --- a/drivers/net/ethernet/marvell/octeontx2/nic/otx2_common.c
> > > +++ b/drivers/net/ethernet/marvell/octeontx2/nic/otx2_common.c
> > > @@ -1705,6 +1705,31 @@ int otx2_nix_config_bp(struct otx2_nic *pfvf,
> > bool enable)
> > > }
> > > EXPORT_SYMBOL(otx2_nix_config_bp);
> > >
> > > +int otx2_nix_cpt_config_bp(struct otx2_nic *pfvf, bool enable)
> > > +{
> > > + struct nix_bp_cfg_req *req;
> > > +
> > > + if (enable)
> > > + req = otx2_mbox_alloc_msg_nix_cpt_bp_enable(&pfvf-
> > >mbox);
> > > + else
> > > + req = otx2_mbox_alloc_msg_nix_cpt_bp_disable(&pfvf-
> > >mbox);
> > > +
> > > + if (!req)
> > > + return -ENOMEM;
> > > +
> > > + req->chan_base = 0;
> > > +#ifdef CONFIG_DCB
> > > + req->chan_cnt = pfvf->pfc_en ? IEEE_8021QAZ_MAX_TCS : 1;
> > > + req->bpid_per_chan = pfvf->pfc_en ? 1 : 0;
> > > +#else
> > > + req->chan_cnt = 1;
> > > + req->bpid_per_chan = 0;
> > > +#endif
> >
> > IMHO, inline #ifdefs reduce readability and reduce maintainability.
> >
> > Would it be possible to either:
> >
> > 1. Include the pfc_en field in struct otx2_nic and make
> > sure it is set to 0 if CONFIG_DCB is unset; or
> > 2. Provide a wrapper that returns 0 if CONFIG_DCB is unset,
> > otherwise pfvf->pfc_en.
> >
> > I suspect 1 will have little downside and be easiest to implement.
>
> pfc_en is already a field of otx2_nic but under CONFIG_DCB. Will fix by adding a wrapper function like:
Thanks. Just to clarify, my first suggestion was to move
pfc_en outside of CONFIG_DCB in otx2_nic.
>
> static bool is_pfc_enabled(struct otx2_nic *pfvf)
> {
> #ifdef CONFIG_DCB
> return pfvf->pfc_en ? true : false;
FWIIW, I think this could also be:
return !!pfvf->pfc_en;
> #endif
> return false;
> }
Also, I do wonder if the following can work:
return IS_ENABLED(CONFIG_DCB) && pfvf->pfc_en;
>
> Using same like..
> ...
> if (is_pfc_enabled(pfvf)) {
If so, perhaps this can work:
if (IS_ENABLED(CONFIG_DCB) && pfvf->pfc_en) {
...
> req->chan_cnt = IEEE_8021QAZ_MAX_TCS;
> req->bpid_per_chan = 1;
> } else {
> req->chan_cnt = 1;
> req->bpid_per_chan = 0;
> }
> ...
Powered by blists - more mailing lists