[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <143ec153-fe71-7a03-a10a-589ecd63eb71@huaweicloud.com>
Date: Tue, 28 May 2024 10:06:16 +0800
From: Li Nan <linan666@...weicloud.com>
To: Christoph Hellwig <hch@...radead.org>
Cc: song@...nel.org, linux-raid@...r.kernel.org,
linux-kernel@...r.kernel.org, yukuai3@...wei.com, yi.zhang@...wei.com,
houtao1@...wei.com, yangerkun@...wei.com
Subject: Re: [PATCH] md: make md_flush_request() more readable
在 2024/5/26 16:54, Christoph Hellwig 写道:
> On Sun, May 26, 2024 at 02:56:22AM +0800, linan666@...weicloud.com wrote:
>> - bio = NULL;
>> - }
>> - spin_unlock_irq(&mddev->lock);
>> -
>> - if (!bio) {
>> + spin_unlock_irq(&mddev->lock);
>> INIT_WORK(&mddev->flush_work, submit_flushes);
>> queue_work(md_wq, &mddev->flush_work);
>> } else {
>> /* flush was performed for some other bio while we waited. */
>> + spin_unlock_irq(&mddev->lock);
>> if (bio->bi_iter.bi_size == 0)
>> /* an empty barrier - all done */
>
> This stil looks like a somwwhat odd flow Why not go all the way
> and turn it into:
>
>
> ...
> queue_work(md_wq, &mddev->flush_work);
> return true;
> }
>
> /* flush was performed for some other bio while we waited. */
> spin_unlock_irq(&mddev->lock);
> if (bio->bi_iter.bi_size == 0) {
> /* pure flush without data - all done */
> bio_endio(bio);
> return true;
> }
> bio->bi_opf &= ~REQ_PREFLUSH;
> return false;
> }
Yeah, it looks better. I will changed it in v2.
Thansk for your suggestion.
--
Thanks,
Nan
Powered by blists - more mailing lists