lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Tue, 28 May 2024 23:27:05 +0300
From: Laurent Pinchart <laurent.pinchart@...asonboard.com>
To: Andy Shevchenko <andy.shevchenko@...il.com>
Cc: linux-kernel@...r.kernel.org, devicetree@...r.kernel.org,
	linux-gpio@...r.kernel.org, linux-pwm@...r.kernel.org,
	Alexandru Ardelean <alexandru.ardelean@...log.com>,
	Bartosz Golaszewski <brgl@...ev.pl>,
	Conor Dooley <conor+dt@...nel.org>,
	Krzysztof Kozlowski <krzk+dt@...nel.org>,
	Lee Jones <lee@...nel.org>,
	Linus Walleij <linus.walleij@...aro.org>,
	Rob Herring <robh@...nel.org>,
	Uwe Kleine-König <ukleinek@...nel.org>,
	Clark Wang <xiaoning.wang@....com>
Subject: Re: [PATCH v2 4/4] pwm: adp5585: Add Analog Devices ADP5585 support

Hi Andy,

Thank you for the review.

On Tue, May 28, 2024 at 10:41:51PM +0300, Andy Shevchenko wrote:
> Tue, May 28, 2024 at 10:03:14PM +0300, Laurent Pinchart kirjoitti:
> > From: Clark Wang <xiaoning.wang@....com>
> > 
> > The ADP5585 is a 10/11 input/output port expander with a built in keypad
> > matrix decoder, programmable logic, reset generator, and PWM generator.
> > This driver supports the PWM function using the platform device
> > registered by the core MFD driver.
> > 
> > The driver is derived from an initial implementation from NXP, available
> > in commit 113113742208 ("MLK-25922-1 pwm: adp5585: add adp5585 PWM
> > support") in their BSP kernel tree. It has been extensively rewritten.
> 
> ...
> 
> > +#include <linux/device.h>
> 
> + err.h
> 
> > +#include <linux/math64.h>
> > +#include <linux/minmax.h>
> > +#include <linux/mfd/adp5585.h>
> > +#include <linux/module.h>
> > +#include <linux/platform_device.h>
> > +#include <linux/pwm.h>
> > +#include <linux/regmap.h>
> > +#include <linux/time.h>

You forgot to mention types.h :-)

> 
> ...
> 
> > +#define ADP5585_PWM_OSC_FREQ_HZ		1000000U
> 
> (1 * HZ_PER_MHZ) ?

If we had an MHZ macro I would use 1 * MHZ, but I don't think HZ_PER_MHZ
improves readability here.

> > +#define ADP5585_PWM_MIN_PERIOD_NS	(2ULL * NSEC_PER_SEC / ADP5585_PWM_OSC_FREQ_HZ)
> > +#define ADP5585_PWM_MAX_PERIOD_NS	(2ULL * 0xffff * NSEC_PER_SEC / ADP5585_PWM_OSC_FREQ_HZ)
> 
> Wouldn't be better to use GENMASK() or (BIT(x) - 1) notation to show that
> the limit is due to HW register bits in use?

I think that would decrease readability to be honest.

> ...
> 
> > +	ret = regmap_write(regmap, ADP5585_PWM_OFFT_LOW,
> > +			   off & 0xff);
> > +	if (ret)
> > +		return ret;
> > +	ret = regmap_write(regmap, ADP5585_PWM_OFFT_HIGH,
> > +			   (off >> 8) & 0xff);
> > +	if (ret)
> > +		return ret;
> > +	ret = regmap_write(regmap, ADP5585_PWM_ONT_LOW,
> > +			   on & 0xff);
> > +	if (ret)
> > +		return ret;
> > +	ret = regmap_write(regmap, ADP5585_PWM_ONT_HIGH,
> > +			   (on >> 8) & 0xff);
> > +	if (ret)
> > +		return ret;
> 
> Can be proper __le16/__be16 be used in conjunction with regmap bulk API?

What I would really like is regmap growing an API similar to
include/media/v4l2-cci.h. Any volunteer ? :-)

> ...
> 
> > +	/* Enable PWM in continuous mode and no external AND'ing. */
> > +	ret = regmap_update_bits(regmap, ADP5585_PWM_CFG,
> > +				 ADP5585_PWM_IN_AND | ADP5585_PWM_MODE |
> > +				 ADP5585_PWM_EN, ADP5585_PWM_EN);
> > +	if (ret)
> > +		return ret;
> > +
> > +	return 0;
> 
> 	return regmap_update_bits(...);
> 
> ...
> 
> > +	regmap_read(regmap, ADP5585_PWM_OFFT_LOW, &off);
> > +	regmap_read(regmap, ADP5585_PWM_OFFT_HIGH, &val);
> > +	off |= val << 8;
> > +
> > +	regmap_read(regmap, ADP5585_PWM_ONT_LOW, &on);
> > +	regmap_read(regmap, ADP5585_PWM_ONT_HIGH, &val);
> > +	on |= val << 8;
> 
> As per above, can it be converted to use proper __le16/__be16 type and
> regmap bulk API?

As there are only 2 registers, I think that's a bit overkill really.

> ...
> 
> > +	device_set_of_node_from_dev(dev, dev->parent);
> 
> Why this one? What's wrong with device_set_node()?

See my reply to 3/4.

-- 
Regards,

Laurent Pinchart

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ